1015 Reversible Primes (20分)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题目大意reversible prime,一个数如果在D进制下,如果它本身(比如73)的它的反转形式(37)都是素数,那么他就是reversible prime。

思路:首先把数转换为D进制的形式,再利用reverse(),分别保存本身的数值(sum1)和反转数的数值(sum2),最后判断两个数是否都为素数,都为素数即可AC。

#include<bits/stdc++.h>
using namespace std;

bool isPrime(int n) {
    if(n<=3)
        return n>1;
    if(n%6!=1&&n%6!=5)
        return false;
    for(int i=5; i<=sqrt(n); i+=6)
        if(n%i==0||n%(i+2)==0)
            return false;
    return true;
}
int main() {
    int n,radix;
    while(cin>>n &&n>1 ) {
        cin>>radix;
        string temp;
        while(n!=0){
            temp+=n%radix+'0';
            n/=radix;
        }
        reverse(temp.begin(),temp.end());
        //cout<<"temp:"<<temp<<endl;
        int sum1=0,sum2=0;
        for(int i=0;i<temp.size();i++){
            sum1*=radix;
            sum1+=temp[i]-'0';
        }
        reverse(temp.begin(),temp.end());
        for(int i=0;i<temp.size();i++){
            sum2*=radix;
            sum2+=temp[i]-'0';
        }
        //cout<<sum1<<" "<<sum2<<endl;
        if(isPrime(sum1)&&isPrime(sum2))
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值