1015 Reversible Primes (20分)菜鸟解答

1015 Reversible Primes (20分)
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10
​5
​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

思路:
我的方法比较笨,没有建立新的函数,只是把验证是否为素数和倒置数值的算法全部整合到主函数里了,而且还重复了一次,就供小白们参考吧~

#include<stdio.h>
#include<iostream>
#include<math.h>

using namespace std;

int main()
{
	int n,m;
	scanf("%d",&n);
    while(n>=0)
    {
    	scanf("%d",&m);
        
    	bool flag=false;
        if(n==1||n==0)
            flag=true;
    for(int k=2;k*k<=n;k++)
	{
		if(n%k==0)
		{
		flag=true;
		break;
	    }
	 } //注意先判断这个数本身是不是素数 
    int consult[100],remainder[100];//设置短除法中的商和余数记录数组 
	int i=0;
	consult[i]=n;
	for(;consult[i]>=m;i++)
	{
		consult[i+1]=consult[i]/m;
	
		remainder[i]=consult[i]%m;

		}
		remainder[i]=consult[i]%m;
	
		int sum=0;
		int j=0;	
	for(j=0;j<=i;j++)
	{
	sum=sum+remainder[i-j]*pow(m,j);//求十进制下倒置的值为多少 
	}
	
	 if(sum==1||sum==0)
            flag=true;
	for(int k=2;k*k<=sum;k++)
	{
		if(sum%k==0)
		{
		flag=true;
		break;
	    }
	 } 
	 if(flag)
	 printf("No\n");
	 else
	 printf("Yes\n");
    scanf("%d",&n);	//更新m和n的值 
	}
	return 0;
 } 

结束。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值