1016 Phone Bills (25分)

 

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

 

#include<bits/stdc++.h>
using namespace std;
struct person{
	string name,status;
	int month,day,hour,minute;
	int totalTime;
}p[1005];
bool cmp(person a,person b){
	return a.name!=b.name?a.name<b.name:a.totalTime<b.totalTime;
}
double billFromZero(person a,int rate[]){
	//int hour1=a.hour,minute1=a.minute,rate1=rate[a.hour];
	//double temp1=rate[a.hour]*a.minute;
	//double temp2=rate[24]*60*a.day;
	double total=rate[a.hour]*a.minute+rate[24]*60*a.day;
	//printf("a.hour=%d a.minute=%d rate[a.hour]=%d\n",hour1,minute1,rate1);
	//printf("rate[a.hour]*a.minute= %.2f\n",temp1);
	//printf("rate[24]*60*a.day= %.2f\n",temp2);
	//printf("total=%.2f\n",total);
	for(int i=0;i<a.hour;i++){
		total+=(rate[i]*60);
	}
	//printf("%.2f\n",total);
	return total/100.0;
}
int rate[25];
int main(){
	for(int i=0;i<24;i++){
		cin>>rate[i];
		rate[24]+=rate[i];
	}
	int n;
	cin>>n;

	for(int i=0;i<n;i++){
		cin>>p[i].name;
		scanf("%d:%d:%d:%d",&p[i].month,&p[i].day,&p[i].hour,&p[i].minute);
		cin>>p[i].status;
		p[i].totalTime=p[i].day*24*60+p[i].hour*60+p[i].minute;
	}

	sort(p,p+n,cmp);
	
	map<string,vector<person>>m;//666
	for(int i=1;i<n;i++){
		if(p[i].name==p[i-1].name&&p[i].status=="off-line"&&p[i-1].status=="on-line"){
			m[p[i-1].name].push_back(p[i-1]);
			m[p[i].name].push_back(p[i]);
		}
	}
	for(auto it:m){
		cout<<it.first;
		vector<person>temp=it.second;
		printf(" %02d\n",temp[0].month);
		double total=0.0;
		for(int i=1;i<temp.size();i+=2){
			double a=billFromZero(temp[i],rate);
			double b=billFromZero(temp[i-1],rate);
			double t=a-b;
			printf("%02d:%02d:%02d %02d:%02d:%02d %d $%.2f\n",temp[i-1].day,temp[i-1].hour,temp[i-1].minute,temp[i].day,temp[i].hour,temp[i].minute,temp[i].totalTime-temp[i-1].totalTime,a-b);
			total+=t;
		}
		printf("Total amount: $%.2f\n",total);
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值