九度OJ 1004

66 篇文章 1 订阅
27 篇文章 0 订阅
题目描述:

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the non-decreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
    Given two increasing sequences of integers, you are asked to find their median.

输入:

    Each input file may contain more than one test case.
    Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤1000000) is the size of that sequence. Then N integers follow, separated by a space.
    It is guaranteed that all the integers are in the range of long int.

输出:

    For each test case you should output the median of the two given sequences in a line.

样例输入:
4 11 12 13 14
5 9 10 15 16 17
样例输出:
13

题目大意:给定两个非递减数组,求出它们的中间元素。具体来说,就是将它们排成一个非递减序列,然后求出中间位置的元素。
由两个数组序列得到另一个由它们组成的非递减的序列,明显用归并排序,时间复杂度在O(m+n)内完成。
归并排序,用两个指针指向数组开头元素,比较首个元素大小,小的那个元素输出,并且指针往后移一个,再进行比较,循环下去直到某一个序列结束,之后就直接将另一个序列的其余元素输出即可。

#include <iostream>
using namespace std;

int main(){
    int n,m;
    long int *a;
    long int *b;
    long int *c;
    while(cin>>n){
        a = new long int[n];
        for(int i=0;i<n;i++)
            cin>>a[i];
        cin>>m;
        b = new long int[m];
        c = new long int[m+n];
        for(int i=0;i<m;i++)
            cin>>b[i];
        int j=0,k=0;
        for(int i=0;i<m+n;i++){
            if(a[j]<b[k] && j<n){
                c[i] = a[j];
                j++;
            }
            else if(a[j]>=b[k] && k<m){
                c[i] = b[k];
                k++;
            }
            if(j == n){
                while(k<m){
                    i++;
                    c[i] = b[k];
                    k++;
                }
                break;
            }
            if(k == m){
                while(j<n){
                    i++;
                    c[i] = a[j];
                    j++;
                }
                break;
            }
        }
        cout<<c[(m+n-1)/2]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值