poj 2096 Collecting bugs

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000



题目大意:s个系统,n种bug,每种bug出现概率相同都为1/n,每种bug等概率出现在每个系统中都为1/s,每个系统有无限个bug,每天找到一个bug,在保证每个系统都至少有一个bug的前提下,求找全n种bug的期望天数。


思路:据说是很简单的概率dp,根本不简单好么...概率dp求期望的关键为逆着递推。对每一个状态进行独立考虑列出所有可能的情况。利用公式求解转移方程:

E(X)=pa*E(A) + pb*E(B) + pc*E(C) + ...... + pn*E(N)。每一个A,B,C代表事件的可能情况,即对应的状态,每一个pa,pb,pc对应当前情况下这些事件可能发生的概率。

移项化简求转移方程。


本题中用dp[i][j]表示找到i种bug,在j个系统中距离完成还差的天数(方便逆推),那么dp[n][s]=0,dp[0][0]即为所求。考虑对每一个新找的bug会有四种情况:

(1).属于已有i个品种,出现在j个系统中

(2).属于已有i个品种,未出现在j个系统中

(3).不属于已有i个品种,出现在j个系统中

(4).不属于已有i个品种,未出现在j个系统中


#include <iostream>
#include <iomanip>
#include <functional>
#include <algorithm>
#include <vector>
#include <string>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <climits>
#include <cctype>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define MP(X,Y) make_pair(X,Y)
#define PB(X) push_back(X)
#define REP(X,N) for(int X=0;X<N;X++)
#define REP2(X,L,R) for(int X=L;X<=R;X++)
#define DEP(X,R,L) for(int X=R;X>L;X--)
#define DEP2(X,R,L) for(int X=R;X>=L;X--)
#define CLR(A,X) memset(A,X,sizeof(A))
#define IT iterator
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> PII;
typedef vector<PII> VII;
typedef vector<int> VI;
#define X first
#define Y second
#define lson(X) ((X)<<1)
#define rson(X) ((X)<<1|1)

double dp[1005][1005];
//dp[i][j]:i种bug,j个每个系统至少含一个bug的离完成还差的时间期望(逆推) 
//dp[i][j]=i/n*j/s*dp[i][j]+i/n*(s-j)/s*dp[i][j+1]+(n-i)/n*j/s*dp[i+1][j]+(n-i)/n*(s-j)/s*dp[i+1][j+1]+1
int main(){
	int n,s;
	while(~scanf("%d%d",&s,&n))
	{
		CLR(dp,0);
		dp[n][s]=0;
		for(int i=n;i>=0;i--){
			for(int j=s;j>=0;j--){
				if(i==n && j==s) continue;
				dp[i][j]=(s-j)*i*1.0/(n*s-i*j)*dp[i][j+1];
				dp[i][j]+=(n-i)*j*1.0/(n*s-i*j)*dp[i+1][j];
				dp[i][j]+=(n-i)*(s-j)*1.0/(n*s-i*j)*dp[i+1][j+1];
				dp[i][j]+=n*s*1.0/(n*s-i*j); //找一次消耗一天 
		//		cout<<i<<' '<<j<<' '<<dp[i][j]<<endl;
			}
		} 
		printf("%.4f\n",dp[0][0]);
			
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值