Maximum Product

Problem D - Maximum Product
Time Limit: 1 second
Given a sequence of integers S = {S1, S2, …, Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input
Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that -10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output
For each test case you must print the message: Case #M: The maximum product is P., where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input
3
2 4 -3

5
2 5 -1 2 -1

Sample Output
8
20

枚举头尾
复杂度O n^2

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

int main(int argc, const char * argv[])
{
	int n;
	
	while(cin >> n)
	{
		int num[20] = {0,};
		int flag = 0;
		long long sum = 1, maxsum = 1;
		
		for(int i = 0; i < n; i++)
			cin >> num[i];
			
		for(int i = 0; i < n; i++)
			for(int j = i; j < n; j++){
				if(j == i)	sum = 1;
				sum *= num[j];
				if(sum >= maxsum){
					maxsum = sum;
					flag = 1;
				}
			}
		
		if(maxsum <= 0 || flag == 0)
			cout << 0 << endl;
		else
			cout << maxsum << endl;
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值