UVA-Maximum Product

Given a sequence of integers S = {S1, S2, … , Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3
2 4 -3
5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.
Case #2: The maximum product is 20.

题意:给定一个序列,找出这个序列中的一个子序列,使得这个序列的乘积为这个序列中所有子序列的最大值,且这个值为正数
方法:使用穷举法,遍历所有的子序列,用一个变量保存当前的最大值,与之后所求得的值一一进行比较,求得最大值;可以通过定义序列的头尾位置,来依次遍历所有的子序列

#include <iostream>
#include <cstdio>

using namespace std;

long long getMax(int num[], int st, int ed){
    long long maxM = 0;
    long long s = 1;
    for(int i = st; i <=ed; i++){
        s *= num[i];
        maxM = maxM > s ? maxM:s;
    }
    return maxM;
}

int main()
{
    int n;
    int cnt = 0;
    while(scanf("%d", &n) == 1 && n){
        int num[20];
        long long maxM = 0;
        for(int i = 0; i < n; i++){
            scanf("%d,", &num[i]);
        }
        for(int i = 0; i < n; i++){
            for(int j = i; j < n; j++){
                long long s = getMax(num, i, j);
                maxM = maxM > s ? maxM:s;
            }
        }
        printf("Case #%d: The maximum product is %lld.\n\n", ++cnt, maxM);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值