HDU 5773 The All-purpose Zero

The All-purpose Zero


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)



Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 

Sample Input
  
  
2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0
 

Sample Output
  
  
Case #1: 5 Case #2: 5
Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.
 
题目解析:
将原数列进行贪心处理,不管怎样,最长上升子序列中0是一定要取的。所以将原数列中所有0取出,并将每一个数减小这个数前面所有0的个数。如 1 2 0 3 4,处理后变为 1 2 2 3,;如1 2 0 0 4 5 ,处理后变为 1 2 2 3。处理后的数列的最长上升子序列长度加上取出的0的个数就是原数列的最长上升子序列长度。
求最长上升子序列时可以使用贪心模拟的方法。我比较熟悉的方法是dp求,其实用贪心模拟的方法更好。至于具体的过程可以从代码中分析一下。

AC代码:
#include <set>
#include <map>
#include <stack>
#include <cmath>
#include <queue>
#include <cstdio>
#include <bitset>
#include <string>
#include <vector>
#include <iomanip>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
#define maxn 100010
#define inf 0x7fffffff
using namespace std;
int a[maxn];
int g[maxn],d[maxn];
int main()
{
        int t;
        scanf("%d", &t);
        for (int tt = 1; tt <= t; tt++)
        {
                int n;
                scanf("%d",&n);
                for(int i=1;i<=n;i++)
                {
                        scanf("%d",&a[i]);
                        g[i]=inf; //g[] 数组用来求最长上升子序列
                }
                int num=0,ans=0; //num储存的是0的个数
                for(int i=1;i<=n;i++)
                {
                        if(a[i]==0)
                        {
                                num++;
                                continue;
                        }
                        a[i]-=num;
                        //贪心求解上升子序列长度
                        int k=lower_bound(g+1,g+1+n,a[i])-g;
                        //d[]存储到第i个数上升子序列长度 a[i]一定要包括在子序列内
                        d[i]=k;
                        g[k]=a[i];
                        ans=max(ans,d[i]);
                }
                printf("Case #%d: %d\n",tt,ans+num);
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值