POJ 3169 Layout ( 最短路径、差分约束)

题目链接:http://poj.org/problem?id=3169

Layout

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12149 Accepted: 5840

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

所有的式子的两边都只出现一个变量,这方程组叫做差分约束系统。

题意:

有N头牛,编号1-N, 他们进食,按照编号顺序站成一排, 在他们之间有些牛,关系好, 所以希望彼此间的距离不超过一定值,有的关系差,希望距离至少是某值, 此外,牛的性格比较倔,所以有可能由多头牛挤在同一位置上,先给出关系好的信息,(AL, BL, DL),再给出关系差的信息( AH, BH, DH ),求1号和N号的最大距离。
如果不存在任何一种排列方法满足条件,则输出-1,无限大则输出-2;

根据题目信息可以确定 d[i] <= d[i+1] ,d[AL] +DL >= d[BL] , d[AH] +DH <= d[BH].

最短路径:记从起点s出发,到各个顶点v的最短距离为d[v], 因此,对于每条权值为 w 的边e=(u, v),都有d[v]<= d[u]+w 成立,反之,在满足全部这些约束不等式的d中, d[v]-d[s]的最大值就是从s到v的最短距离。最短距离对应着最大值。

将原来的问题转化成最短距离的问题求解,其中原来的不等式转化为边的关系如下。
为了方便找边的关系,最好写成最短路中状态转移的形式,左边一个变量,右边一个变量加边权,写成小于号,那么当大于的时候就转移。

1. d[i]<= d[i+1]   => d[i]<= d[i+1]+0;
2. d[AL]+DL>=d[BL] => d[BL]<=d[AL]+DL;  // AL->BL 边权为DL
3. d[AH]+DH<=d[BH] => d[AH]<=d[BH]-DH; // BH->AH 边权为-DH

因为牛按照序号依次排列,设a牛在前,b牛在后,只要a牛位置确定,则再确定b牛位置即可,也就是只要a->b的关系,单向边。因为从1开始进行确定位置,所有从小到大依次去确定即可,也就是单边就够了。如果双向边,就一定会出现负环,不符合题意。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int N = 1005;
const int INF = 0x3f3f3f3f;
struct edge {
    int to, next;
    int dist;
}graph[200010];
int totlen;
int head[N];
int n, ml, md;
int dist[N];
int num[N];
bool visit[N];
int que[N];
bool spfa(int s) {
    for(int i = 0; i <= n; i++) dist[i] = INF;
    for(int i = 0; i <= n; i++) num[i] = 0;
    for(int i = 0; i <= n; i++) visit[i] = 0;
    int front = 0, tail = 0;    
    dist[s] = 0;
    que[tail++] = s;
    while(front != tail) {
        int u = que[front++];
        if(front == N) front = 0;
        visit[u] = 0;
        for(int i = head[u]; i != -1; i = graph[i].next) {
            int v = graph[i].to;
            if(dist[v] > dist[u]+graph[i].dist) {
                dist[v] = dist[u]+graph[i].dist;
                if(!visit[v]) {
                    if(++num[v] == n) return true;
                    visit[v] = 1;
                    que[tail++] = v;
                    if(tail == N) tail = 0;
                }
            }
        }
    }
    return false;

}
void addEdge(int u, int v, int w) {
    graph[totlen].to = v;
    graph[totlen].next = head[u];
    graph[totlen].dist = w;
    head[u] = totlen++;
}
void init() {
    memset(head, -1, sizeof(int)*(n+3));
    totlen = 0;
}
int main() {
    while(~scanf("%d%d%d", &n, &ml, &md)) {
        init();
        for(int i = 0; i < ml; i++) {
            int u, v, w;
            scanf("%d%d%d", &u, &v, &w);
            addEdge(u, v, w);
        }
        for(int i = 0; i < md; i++) {
            int u, v, w;
            scanf("%d%d%d", &u, &v, &w);
            addEdge(v, u, -1*w);
        }
        if(spfa(1)) {
            printf("-1\n");
        }else if(dist[n] == INF) {
            printf("-2\n");
        }else {
            printf("%d\n", dist[n]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值