February 29 --容斥原理

It is 2012, and it's a leap year. So there is a "February 29" in this year, which is called leap day. Interesting thing is the infant who will born in this February 29, will get his/her birthday again in 2016, which is another leap year. So February 29 only exists in leap years. Does leap year comes in every 4 years? Years that are divisible by 4 are leap years, but years that are divisible by 100 are not leap years, unless they are divisible by 400 in which case they are leap years.

In this problem, you will be given two different date. You have to find the number of leap days in between them.

Input

Input starts with an integer T (≤ 550), denoting the number of test cases.

Each of the test cases will have two lines. First line represents the first date and second line represents the second date. Note that, the second date will not represent a date which arrives earlier than the first date. The dates will be in this format - "month day, year", See sample input for exact format. You are guaranteed that dates will be valid and the year will be in between 2 * 103 to 2 * 109. For your convenience, the month list and the number of days per months are given below. You can assume that all the given dates will be a valid date.

Output

For each case, print the case number and the number of leap days in between two given dates (inclusive).

Sample Input

4

January 12, 2012

March 19, 2012

August 12, 2899

August 12, 2901

August 12, 2000

August 12, 2005

February 29, 2004

February 29, 2012

Sample Output

Case 1: 1

Case 2: 0

Case 3: 1

Case 4: 3

分析:

暴力超时,用数学的容斥原理,分别计算从0到开始年份和结束年份的满足的润日数,设为b-a,那么包含的是

包含的是不包括起始年份但是包括结束年份的润日数,接下来就是再判断起始,如果是闰年并且月份小于等于

2,加一;如果结束年份不是闰年无所谓,如果是,那么只有月份大于2时或者月份等于2并且日子大于等于29才

满足条件,否则就要减一,因为b-a区间包括了结束年份。上代码:

 

/*容斥原理:
 *  A∪B = A+B-A∩B;
 *  暴力枚举会超时,
 *  (year%4==0&&year%100!=0)||year%400==0
 *  上面这句话容斥原理的条件,画图即可理解
 * */
import java.util.*;
 public  class Main{
    static Scanner in = new Scanner(System.in);
    static boolean judgeYear(long year){
    	
    	return (year%4==0&&year%100!=0)||year%400==0;
    }
    public static void main(String args[]){ 
     String[] months = {"","January", "February", "March", "April", "May", 
    			"June", "July", "August", "September", "October", "November","December"};
       Map<String,Integer> moth = new HashMap<>();
       for (int i = 1; i <= 12; i++) {
		    moth.put(months[i], i);
	   }
        int k=in.nextInt();  
        int ca = 0;
        long cnt;
        while(k-->0){ 
         	ca++;
        	cnt = 0;
        	String m1 = in.next();
        	String d1 = in.next();		
        	long y1 = in.nextLong();


        	String m2 = in.next();
        	String d2 = in.next();		
        	long y2 = in.nextLong(); 
            cnt = ((y2/4-y2/100+y2/400)-(y1/4-y1/100+y1/400));
            if(judgeYear(y1)){
        	  if(moth.get(m1)<=2)
        		  cnt++;      		  
            }
            if(judgeYear(y2)){          	
            	int d = Integer.valueOf(d2.substring(0, 2));
        	  if(moth.get(m2)==1||(moth.get(m2)==2&&d<29))
        		  cnt--;      		  
            }	
       System.out.println("Case "+ca+": "+cnt);     
        }     
    }    
}
	
    	return (year%4==0&&year%100!=0)||year%400==0;
    }
    public static void main(String args[]){ 
     String[] months = {"","January", "February", "March", "April", "May", 
    			"June", "July", "August", "September", "October", "November","December"};
       Map<String,Integer> moth = new HashMap<>();
       for (int i = 1; i <= 12; i++) {
		    moth.put(months[i], i);
	   }
        int k=in.nextInt();  
        int ca = 0;
        long cnt;
        while(k-->0){ 
         	ca++;
        	cnt = 0;
        	String m1 = in.next();
        	String d1 = in.next();		
        	long y1 = in.nextLong();


        	String m2 = in.next();
        	String d2 = in.next();		
        	long y2 = in.nextLong(); 
            cnt = ((y2/4-y2/100+y2/400)-(y1/4-y1/100+y1/400));
            if(judgeYear(y1)){
        	  if(moth.get(m1)<=2)
        		  cnt++;      		  
            }
            if(judgeYear(y2)){          	
            	int d = Integer.valueOf(d2.substring(0, 2));
        	  if(moth.get(m2)==1||(moth.get(m2)==2&&d<29))
        		  cnt--;      		  
            }	
       System.out.println("Case "+ca+": "+cnt);     
        }     
    }    
}

 

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值