杭电1874-畅通工程续

Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
 

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
 

Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
 

Sample Input
  
  
3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2
 

Sample Output
  
  
2

-1

一道简单的单源最短路径模板题。用了Dijkstra算法,同时用优先队列维护。

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<stack>
#include<queue>
#include<vector>
#include<iostream>
using namespace std;

#define INF 1000010000   //定义一个很大的数 

struct Node  
{  
	int num,val;   //存放结点编号和到初始点的距离   
}nod; 

vector<Node> vv[205];
bool book[205];  //检查这个点是否用过   
int dis[205];     //到原点最短距离   
//int D[100][100];  //记录路径长度  
int V,E;   
int start,endd;
int len,to;

priority_queue<Node> que;   //优先从小到大  

void Init()
{
	while(!que.empty()) que.pop(); //清空  
	
	for(int i=0;i<=204;i++)
	vv[i].clear();
	
	memset(book,0,sizeof(book));  
	//memset(D,-1,sizeof(D));
}
  
bool operator < (Node a,Node b)  
{  
	if(a.val == b.val) return a.num>b.num;  
	return a.val>b.val;              //先出小   
} 
  
int main()  
{  
	int a,b,d;  
	while(cin>>V>>E)  //输入顶点数和边数   
	{
		Init();
		for(int i=0;i<E;i++)  
		{  
			cin>>a>>b>>d;
			nod.num = b;
			nod.val = d;
			vv[a].push_back(nod);
			
			nod.num = a;
			vv[b].push_back(nod);  
		}  
		cin>>start>>endd;
		
		dis[start] = 0;  
		for(int i=0;i<V;i++)  
		if(i!=start) dis[i]=INF;  
  
		nod.num=start;  
		nod.val=0;  
		  
		que.push(nod);   //将起点放入队列   
		  
		while(!que.empty())  //不为空时   
		{
			Node temp = que.top();
			int t = temp.num;
			len = vv[t].size();
  			for(int i=0; i<len; i++)
  			{
  				Node tt = vv[t][i], tp;
  				to = tt.num;
			  	if(!book[to] && dis[to] > dis[t] + tt.val)
			  	{
	  				dis[to] = dis[t] + tt.val;
	  				
	  				tp.num = to;  //这个点的序号 
	  				tp.val = dis[to];  //这个点到起点的距离 
	  				que.push(tp);
	  			}
			}
			
			book[temp.num] = true;
			que.pop();  
		}  
		
		if(dis[endd] != INF)
		cout<<dis[endd]<<endl;
		else
		cout<<-1<<endl; 
	  
	}  
	return 0;  
}  


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值