Prime Path 变素数问题(bfs)

点击打开链接

//变 素数问题  广搜也要记得标记 ,要不然重复的元素会压到队列       筛素数 

Problem Description
The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
 

Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
 

Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
 

Sample Input
  
  
3 1033 8179 1373 8017 1033 1033
 

Sample Output
  
  
6 7 0


#if 0
#include<iostream>
#include<cstring>
#include<queue>
#include<cmath>
using namespace std;

int prime[10000];
bool vis[10000];

void goprime()                               //dabiao
{
	prime[0]=prime[1]=0;prime[2]=1;
	for(int i=3; i<=10000; i++)
	{
		if(i%2==0)
		{
			prime[i]=0;
		}
		else
		{
			prime[i]=1;
		}
	}
	int k=sqrt(10000);
	for(int i=2; i<=k; i++)
	{
		if(prime[i])
		for(int j=i*i; j<=10000; j+=2*i)
		{
			prime[j]=0;
		}
		
	}
	
}

struct go
{
	int x,t;	
}a,b;

void bfs()
{
	queue<go> q;
	q.push(a);
	
	while(!q.empty())
	{
		go it;
		it=q.front();
		q.pop();
		 
		if(it.x==b.x)
		{
			cout<<it.t<<endl;
			return;
		}
		
		int x1,x2,x3,x4;
		x1=it.x/1000;
		x2=it.x%1000/100;
		x3=it.x%100/10;
		x4=it.x%10;
		go its;
		
		for(int i=1; i<10; i++)
		{
			if(x1!=i)
			{
				int x=i*1000+x2*100+x3*10+x4;
				if(prime[x] && !vis[x])
				{
					vis[x]=1;
					its.x=x;
					its.t=it.t+1;
					q.push(its);
				}
			}
		}
		
		for(int i=0; i<10; i++)
		{
			if(x2!=i)
			{
				int x=x1*1000+i*100+x3*10+x4;
				if(prime[x] && !vis[x])
				{
					vis[x]=1;
					its.x=x;
					its.t=it.t+1;
					q.push(its);
				}
			}
		}
		
		for(int i=0; i<10; i++)
		{
			if(x3!=i)
			{
				int x=x1*1000+x2*100+i*10+x4;
				if(prime[x] && !vis[x])
				{
					vis[x]=1;
					its.x=x;
					its.t=it.t+1;
					q.push(its);
				}
			}
		}
		
		for(int i=0; i<10; i++)
		{
			if(x4!=i)
			{
				int x=x1*1000+x2*100+x3*10+i;
				if(prime[x] && !vis[x])
				{
					vis[x]=1;
					its.x=x;
					its.t=it.t+1;
					q.push(its);
				}
			}
		}
			
	} 
	
	cout<<"Impossible"<<endl;
	return;
}


int main()
{
	int n;
	cin>>n;
	goprime();
	
	while(n--)
	{
		memset(vis,0,sizeof(vis));
		cin>>a.x>>b.x;
		a.t=b.t=0;
		vis[a.x]=1;
		bfs();
	}
}
#endif 
 









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值