Shredding Company

Problem Description
You have just been put in charge of developing a new shredder for the Shredding Company Although a "normal" shredder would just shred sheets of paper into little pieces so that the contents would become unreadable, this new shredder needs to have the following unusual basic characteristics.

1.The shredder takes as input a target number and a sheet of paper with a number written on it.

2.It shreds (or cuts) the sheet into pieces each of which has one or more digits on it.

3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it.

For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination's 43. The combination of 12, 34, and 6 is not valid either, because the sum 52 (= 12 + 34 + 6) is greater than the target number of 50.

Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50


There are also three special rules :

1.If the target number is the same as the number on the sheet of paper, then the paper is not cut.

For example, if the target number is 100 and the number on the sheet of paper is also 100, then

the paper is not cut.

2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed.

3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules. Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shredder should "cut up" the second number.

 

Input
The input consists of several test cases, each on one line, as follows :< br>< br>tl num1< br>t2 num2< br>...< br>tn numn< br>0 0< br>< br>Each test case consists of the following two positive integers, which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded.< br>< br>Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input.< br>< br>
 

Output
For each test case in the input, the corresponding output takes one of the following three types :< br>< br>sum part1 part2 ...< br>rejected< br>error< br>< br>In the first type, partj and sum have the following meaning :< br>< br>1.Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper.< br>< br>2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +...< br>< br>Each number should be separated by one space.< br>The message error is printed if it is not possible to make any combination, and rejected if there is< br>more than one possible combination.< br>No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line.< br>
 

Sample Input
  
  
50 12346 376 144139 927438 927438 18 3312 9 3142 25 1299 111 33333 103 862150 6 1104 0 0
 

Sample Output
  
  
43 1 2 34 6 283 144 139 927438 927438 18 3 3 12 error 21 1 2 9 9 rejected 103 86 2 15 0 rejected
  
  
 
题意;主要将的是一个数n,然后把这个数分成若干个,将这些分成若干的数字加起来,求出不超过n 的最大的数字和。如果最小的和都超过n,那么就error; 如果最大的数字和有两个,输出rejected ;
dfs,给了一个数,数字的第一个数字有两种选择,一种是单独分出去,一种是和后面的结合在组成一个新的数。
第一看感觉确实是复杂,分出两路来了,又发现代码写不出来,尤其的在不知道要用数组盛放数字的时候,放了好几天,今天知道室友跟我说用数组放数字的时候,理清思路,终于写出来了。

//dfs     
#if 0
#include<iostream>
#include<cstring>
using namespace std;
int n,a[10],t[10],end[10];        //a 开始的数组   t一直变换的数组 end最后结果的数组 
int D=0,num,lenth;
string s;

void dfs(int sum,int x,int p, int len)                  // 0 a[0] 0 0
{ 
	//cout<<"123000"<<endl; 
	
	if(sum>n) 
		return;
	if(p==s.size())                       //搜到底      
	{
		sum+=x;
		t[len]=x;
		/*for(int i=1; i<=len; i++)  
		{
			cout<<t[i]<<" ";
		}*/
		//cout<<endl<<"*************************"<<endl;  
		
		if(sum>n) 
			return;
			
		if(sum>D) 
		{
			D=sum;
			num=1;
			lenth=len;
			
			for(int i=1; i<=lenth; i++)
			{
				end[i]=t[i];
			}
		}
		else
		if(sum==D)
		{
			num=2;		
		}	
		return;
		
	}
	

		
		dfs(sum,x*10+a[p+1],p+1,len); 
		t[len]=x;
		len+=1; 
		dfs(sum+x,a[p+1],p+1,len);  	
		t[len]=0;
			
}

int main()
{
	while(cin>>n>>s)
	{
		if(n==0&&s=="0")
			break;
			
		D=0; num=0;
		memset(a,0,sizeof(a));
		memset(end,0,sizeof(end));
		memset(t,0,sizeof(t));
			
		for(int i=1; i<=s.size(); i++)
		{
			a[i]=s[i-1]-'0';
		}
	
	
			
		dfs(0,a[1],1,1);
	       
		if(num==0) 
		{
			cout<<"error"<<endl; 
		} 
		else 
		if(num==2)
		{
			cout<<"rejected"<<endl;
		}
		else
		{
			cout<<D;
			for(int i=1; i<=lenth; i++)
			{
				cout<<" "<<end[i];
			}
			cout<<endl;
		} 
	
	}

}
#endif 










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值