Satellite Photographs(dfs)

Farmer John purchased satellite photos of W x H pixels of his farm (1 <= W <= 80, 1 <= H <= 1000) and wishes to determine the largest 'contiguous' (connected) pasture. Pastures are contiguous when any pair of pixels in a pasture can be connected by traversing adjacent vertical or horizontal pixels that are part of the pasture. (It is easy to create pastures with very strange shapes, even circles that surround other circles.)

Each photo has been digitally enhanced to show pasture area as an asterisk ('*') and non-pasture area as a period ('.'). Here is a 10 x 5 sample satellite photo:

..*.....**
.**..*****
.*...*....
..****.***
..****.***


This photo shows three contiguous pastures of 4, 16, and 6 pixels. Help FJ find the largest contiguous pasture in each of his satellite photos.      

Input
* Line 1: Two space-separated integers: W and H

* Lines 2..H+1: Each line contains W "*" or "." characters representing one raster line of a satellite photograph.
Output
* Line 1: The size of the largest contiguous field in the satellite photo.
Sample Input

10 5
..*.....**
.**..*****
.*...*....
..****.***
..****.***
Sample Output
16

给你一个图,有* 和 .,*是被.隔离成若干块,求这若干块中*数量最多是多少?


#if 0
#include<iostream>
#include<cstring>
using namespace std;
int n,m,maxx,cnt;
char a[1010][1010];
bool vis[1010][1010];
int f[4][2]={{1,0},{-1,0},{0,1},{0,-1}}; 

bool ok(int i,int j)
{
	if(i>=1&&i<=n&&j>=1&&j<=m) 
	{
		
			return 1; 
	}
	
	return 0; 
}


void dfs(int x,int y) 
{
	
		
		if(ok(x,y)==0) 
		{
			return;
		}
		
		if(a[x][y]=='*'&&vis[x][y]==0)
		{
			vis[x][y]=1;
			cnt++;
			
			for(int i=0; i<4; i++)
			{
				int xi=x+f[i][0];
				int yi=y+f[i][1];
				dfs(xi,yi);				
			}
		}
	
	
	
}
	
int main()
{
	while(cin>>m>>n)
	{
		memset(a,0,sizeof(a));
		memset(vis,0,sizeof(vis));
		cnt=0;
		
		for(int i=1; i<=n; i++)
		{
			for(int j=1; j<=m; j++)
			{
				cin>>a[i][j];	
			}
		}
		
		for(int i=1; i<=n; i++)
		{
			for(int j=1; j<=n; j++)
			{
				cnt=0;
				if(!vis[i][j]&&ok(i,j)) 
				{
					dfs(i,j);	
		
					if(cnt>maxx)
					{
						maxx=cnt; 
					}
				}	
			}	
		} 
		cout<<maxx<<endl;
	}
	
}
#endif



















  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值