图的深搜应用-Satellite Photographs

Description

Farmer John purchased satellite photos of W x H pixels of his farm (1 <= W <= 80, 1 <= H <= 1000) and wishes to determine the largest ‘contiguous’ (connected) pasture. Pastures are contiguous when any pair of pixels in a pasture can be connected by traversing adjacent vertical or horizontal pixels that are part of the pasture. (It is easy to create pastures with very strange shapes, even circles that surround other circles.)

Each photo has been digitally enhanced to show pasture area as an asterisk (‘*’) and non-pasture area as a period (‘.’). Here is a 10 x 5 sample satellite photo:

..*.....** 
.**..***** 
.*...*.... 
..****.*** 
..****.*** 

This photo shows three contiguous pastures of 4, 16, and 6 pixels. Help FJ find the largest contiguous pasture in each of his satellite photos.

Input

  • Line 1: Two space-separated integers: W and H

  • Lines 2..H+1: Each line contains W “*” or “.” characters representing one raster line of a satellite photograph.

Output

  • Line 1: The size of the largest contiguous field in the satellite photo.

Sample Input

10 5
..*.....**
.**..*****
.*...*....
..****.***
..****.***

Sample Output

16

Source

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

#define debug
#define Width_MAX   80
#define Height_MAX  100

int count_num = 0;
int Width,Height;
char map[Height_MAX+2][Width_MAX+2];

void dfs(int x, int y)
{
    if(map[x][y] == '.' )
        return;
    map[x][y] = '.';
    count_num ++;
    dfs(x+1, y);
    dfs(x-1, y);
    dfs(x, y+1);
    dfs(x, y-1);
}

int main()
{

    int max = 0;
    memset(map,'.',sizeof(map));
    scanf("%d %d",&Width,&Height);
    for(int i = 1; i <= Height; i++)
    {
        getchar();
        for(int j = 1; j <= Width; j++)
        {
            scanf("%c",&map[i][j]);
        }

    }

    #ifdef debug
    printf("\n");
    printf("\n");

    for(int i = 1; i <= Height; i++)
    {

        for(int j = 1; j <= Width; j++)
        {
            printf("%c",map[i][j]);
        }
        printf("\n");
    }
    #endif // debug


    for(int i = 1; i <= Height; i++)
    {
        for(int j = 1; j <= Width; j++)
        {
            count_num = 0;
            if(map[i][j] == '*')
                dfs(i,j);
            if (max < count_num)
                max = count_num;

        }
    }

    printf("%d \n",max);
}

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值