线段树—Just a Hook(区间更新,区间求和)

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
Sample Output
  
  
Case 1: The total value of the hook is 24.
题意:

给你n个元素,初始化都是1;输入a,b,c ,将[a,b]区间里的元素的值改为c(这里c={1,2,3})
经过几次改变,最后求这n个元素的和。 
一个区间的更新带来两个变化,一个是该区间内的小区间的变化,我们用pushdown()操作的;一个是包含该区间的大区间的变化,我们用的pushup()操作的。
这个题也是关于线段树很基础的操作。。。但是初次实现代码还是出现很多错。。需要更多的练习。
#if 0
#include<iostream>
using namespace std;
const int MAXX=1e5;
int sum[MAXX*4];
int setv[MAXX*4];
#define lson l,m,id*2
#define rson m+1,r,id*2+1
void pushup(int id)
{
	sum[id]=sum[id*2]+sum[id*2+1];	
} 
void pushdown(int id,int num)
{
	if(setv[id])
	{
		setv[id*2+1]=setv[id*2]=setv[id];
		sum[id*2]=(num-num/2)*setv[id];
		sum[id*2+1]=num/2*setv[id];
		setv[id]=0;	
	}		
} 
void build(int l,int r,int id)
{
	setv[id]=0;
	sum[id]=1;
	if(l==r)
		return;
	int m=(l+r)/2;
	build(lson);
	build(rson);
	pushup(id);	
}
void update(int ql,int qr,int val,int l,int r,int id)
{
	if(ql<=l&&qr>=r)
	{
		setv[id]=val;
		sum[id]=(r-l+1)*val;
		return;	
	}	
	pushdown(id,r-l+1);
	int m=(l+r)/2;
	if(ql<=m) 
		update(ql,qr,val,lson); /
	if(qr>m)
		update(ql,qr,val,rson);	
	pushup(id);
} 
int query(int ql,int qr,int l,int r,int id)
{
	if(ql<=l&&qr>=r)
	{
		return sum[id];
	}
	pushdown(id,r-l+1);            ///
	int m=(l+r)/2;
	int ret=0;
	if(ql<=m)   
	{
		ret+=query(ql,qr,lson);
	}
	if(qr>m)
	{
		ret+=query(ql,qr,rson);
	}
	return ret;		
} 

int main()
{
	while(1)
	{
		int a,b,n,val;
		cin>>n;	
		build(1,n,1);
		char s;
		while(1)
		{
			cin>>s;
			if(s=='k')
				break;
			if(s=='q')
			{
				cin>>a>>b;
				cout<<query(a,b,1,n,1)<<endl;
			}
			else
			{
				cin>>a>>b>>val;
				update(a,b,val,1,n,1);
			}
		}	
	}	
}
#endif 
 
 
 










 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值