多校1001 HDU-6033. Add More Zero 水

本文解析了HDU6033 AddMoreZero题目,介绍了一种求解特定范围内整数位数的方法。通过计算log(2^m)来确定最大可能的k值,使得所有在1到10^k范围内的整数能在特定类型的超级计算机上进行计算。
摘要由CSDN通过智能技术生成

题目链接:HDU 6033
Add More Zero

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2245 Accepted Submission(s): 1053

Problem Description
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).

As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive).

For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.

Input
The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1≤m≤105.

Output
For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input
1
64

Sample Output
Case #1: 0
Case #2: 19

大意:
给出一个 m ,求(2^m-1) 用十进制要用多少位(个)数字表示。
要点在于快速看懂题意。
解法:
由于 10 的幂和 2 的幂不会相等,所以 求 log(2m1) 等价于求 log(2m) 等价于 mlog2
代码实现:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define mem(s,t) memset(s,t,sizeof(s))
#define D(v) cout<<#v<<" "<<v<<endl
#define inf 0x3f3f3f3f
//#define LOCAL
const ll MAXN =1e5+10;
int main() {
#ifdef LOCAL
    freopen("1002.in","r",stdin);
    freopen("out.txt","w",stdout);
#endif
    int n,kase=0;
    while(~scanf("%d",&n)){
        printf("Case #%d: %d\n",++kase,int(n*log10(2)));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值