题目链接:HDU 6033
Add More Zero
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2245 Accepted Submission(s): 1053
Problem Description
There is a youngster known for amateur propositions concerning several mathematical hard problems.
Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between 0 and (2m−1) (inclusive).
As a young man born with ten fingers, he loves the powers of 10 so much, which results in his eccentricity that he always ranges integers he would like to use from 1 to 10k (inclusive).
For the sake of processing, all integers he would use possibly in this interesting problem ought to be as computable as this supercomputer could.
Given the positive integer m, your task is to determine maximum possible integer k that is suitable for the specific supercomputer.
Input
The input contains multiple test cases. Each test case in one line contains only one positive integer m, satisfying 1≤m≤105.
Output
For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.
Sample Input
1
64
Sample Output
Case #1: 0
Case #2: 19
大意:
给出一个 m ,求(2^m-1) 用十进制要用多少位(个)数字表示。
要点在于快速看懂题意。
解法:
由于 10 的幂和 2 的幂不会相等,所以 求
log(2m−1)
等价于求
log(2m)
等价于
mlog2
代码实现:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define mem(s,t) memset(s,t,sizeof(s))
#define D(v) cout<<#v<<" "<<v<<endl
#define inf 0x3f3f3f3f
//#define LOCAL
const ll MAXN =1e5+10;
int main() {
#ifdef LOCAL
freopen("1002.in","r",stdin);
freopen("out.txt","w",stdout);
#endif
int n,kase=0;
while(~scanf("%d",&n)){
printf("Case #%d: %d\n",++kase,int(n*log10(2)));
}
return 0;
}