【JAVA】HDU 1312 Red and Black(DFS水题)

7 篇文章 0 订阅

先上原题:

                                Red and Black
                 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                 Total Submission(s): 21177    Accepted Submission(s): 12911

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
….#.
…..#
……
……
……
……
……
#@…#
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..

.

…@…

.

..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

一道很简单的DFS水题,不必考虑剪枝可以直接过,题意大致是:
在给定的有起点的房间里面,一个可以通过’.’而不能通过’#’的人能到达多少方格,需要注意的是,起点也包含在内。

用JAVA暴力深搜一遍AC了,代码如下:

import java.util.Scanner;

public class Main{

    static int w = 0;//每个测试房间的宽度
    static int h = 0;//每个测试房间的高度
    static char room[][] = new char[21][21];//房间
    static int sum = 1;//计算可到达的方格

    public static void main(String args[]){
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            w = sc.nextInt();
            h = sc.nextInt();
            if(w == 0 && h == 0)break;
            String a = "";
            for(int i = 0;i < h;i++){
                a = sc.next();
                room[i] = a.toCharArray();
            }

            //遍历房间寻找起点
            int x = 0,y = 0;
            for(int i = 0;i < h;i++){
                for(int j = 0;j < w;j++){
                    if(room[i][j] == '@'){
                        x = j;
                        y = i;
                    }
                }
            }

            dfs(x,y);
            System.out.println(sum);
            sum = 1;
        }
    }

    static void dfs(int x, int y){
        if( y >= 0 && x >= 0 && y < h && x < w){
        if(room[y][x] == '#')return;//不可前进时停止
            if(room[y][x] == '.')
                ++sum;//计数
        }
        else return;//到达房间边缘时停止

        room[y][x] = '#';//将走过的地板变为不可行走

        //继续前进
        dfs(x-1,y);
        dfs(x+1,y);
        dfs(x,y-1);
        dfs(x,y+1);
    }

}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值