hdu1312 Red and Black_广搜 dfs(java版本)

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20220    Accepted Submission(s): 12311


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
题目大意: 一个地图里面有三种元素,分别为"@",".","#",其中@为人的起始位置,"#"可以想象为墙,然后.为可以走的空地,求人可以走的最大点数。 解题思路: 好吧,搜索入门题,直接广度搜索,标志入队的次数。入队的次数即为行走的步数。 代码:
AC代码:
package 六月第一周;

import java.util.LinkedList;
import java.util.Queue;
import java.util.Scanner;

public class hdu1312 {

	/**
	 * @param args
	 */
	static int dir[][]={{-1,0},{0,1},{1,0},{0,-1}};//上,右,下,左
	static int MAX=25;
	static boolean  vis[][]=new boolean [MAX][MAX];//访问标志
	static char map[][]=new char[MAX][MAX];
	static int n,m;
	static int s_x,s_y;//开始的位置
	static int step;
	class Node{//定义每个位置的类
		int x;
		int y;
	}
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner scan=new Scanner(System.in);
		while((n=scan.nextInt())!=0&&(m=scan.nextInt())!=0){
			String str=scan.nextLine();//接收回车符
			for(int i=0;i<m;i++){
				str=scan.nextLine();
				char b[]=str.toCharArray();
				for(int j=0;j<n;j++){
					map[i][j]=b[j];
					if(map[i][j]=='@'){
						s_x=i;
						s_y=j;
					}
				}
			}
			int ans=bfs();
			System.out.println(ans);
		}
	}
	private static int bfs() {
		// TODO Auto-generated method stub
		//初始化
		step=0;
		for(int i=0;i<m;i++){
			for(int j=0;j<n;j++){
				vis[i][j]=false;
			}
		}
		Queue<Node> queue=new LinkedList<Node>();
		hdu1312 hdu=new hdu1312();
		Node node=hdu.new Node();
		node.x=s_x;
		node.y=s_y;
		
		vis[s_x][s_y]=true;
		queue.offer(node);
		while(queue.size()!=0){
			Node node1=queue.poll();
			step++;
			for(int i=0;i<4;i++){
				int xx=node1.x+dir[i][0];
				int yy=node1.y+dir[i][1];
				if(xx>=0&&xx<m&&yy>=0&&yy<n&&!vis[xx][yy]&&map[xx][yy]=='.'){
					vis[xx][yy]=true;
					Node node2=hdu.new Node();
					这里非常坑的一点就是 直接使用前面定义
					//node这个区赋值 加入队列的话 会改变上一个node加入队列的值 到最后 加入的节点 是最后一次的赋值 必须要重新new一个
					//类
					node2.x=xx;
					node2.y=yy;
				
					queue.offer(node2);
				}
			}
		}
		return step;
	}

}


//dfs代码
import java.util.Scanner;

public class hdu1312dfs {

	/**
	 * @param args
	 */
	static int dir[][]={{-1,0},{0,1},{1,0},{0,-1}};//上,右,下,左
	static int MAX=25;
	static char map[][]=new char[MAX][MAX];
	static int n,m;
	
	static int step=0;
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner scan=new Scanner(System.in);
		while((n=scan.nextInt())!=0&&(m=scan.nextInt())!=0){
			int s_x = 0,s_y = 0;//开始的位置
			String str=scan.nextLine();//接收回车符
			for(int i=0;i<m;i++){
				str=scan.nextLine();
				char b[]=str.toCharArray();
				for(int j=0;j<n;j++){
					map[i][j]=b[j];
					if(map[i][j]=='@'){
						s_x=i;
						s_y=j;
					}
				}
			}
			step=0;
			dfs(s_x,s_y);
			System.out.println(step);
		}
	}
	private static void dfs(int x,int y) {
		// TODO Auto-generated method stub
		map[x][y]='#';
		step++;
		for(int i=0;i<4;i++){
			int xx=x+dir[i][0];
			int yy=y+dir[i][1];
			if(xx>=0&&xx<m&&yy>=0&&yy<n&&map[xx][yy]=='.'){
				dfs(xx,yy);
			}
		}
		return ;
	}

}


 
 
 
 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值