PAT甲级 1037 Magic Coupon (25 分)(贪心)

1037 Magic Coupon (25 分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

题目要求: 

给出两个数组,求他们中间数据乘积的最大和

解题思路:

对每个数组进行排序,

将最大的负数和最大的负数相乘+倒数第二大的负数相乘……

将最大的正数和最大的正数相乘+倒数第二大的正数相乘……

算出他们的和

注意:

1.题目上的范围虽然给的很大,然而数据很弱,用Int型就可以了

完整代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int main(){
	int Nc,Np;
	int i,p,q;
	int result=0;
	cin>>Nc;
	vector<int> v1(Nc);
	for(i=0;i<Nc;i++){
		scanf("%d",&v1[i]);
	}
	cin>>Np;
	vector<int> v2(Np);
	for(i=0;i<Np;i++){
		scanf("%d",&v2[i]);
	}
	sort(v1.begin(),v1.end());
	sort(v2.begin(),v2.end());
	p = 0;q = 0;
	while(v1[p] < 0 && v2[q] < 0 && p < Nc-1 && q < Np-1){
		result+=v1[p]*v2[q];
		p++;q++;
	}
	p = Nc-1; q = Np-1;
	while(v1[p] > 0 && v2[q] > 0 && p >=0 && q >=0){
		result+=v1[p]*v2[q];
		p--;q--;
	}
	cout<<result<<endl;	
}

简化算法

2019.2.9

#include<bits/stdc++.h>
using namespace std;

int main(){
	int nc,np,i,j;
	int c[100010],p[100010];
	long long sum=0;
	cin>>nc;
	for(i=0;i<nc;i++) cin>>c[i];
	cin>>np;
	for(i=0;i<np;i++) cin>>p[i];
	sort(c,c+nc);
	sort(p,p+np);
	i=0;j=0;
	while(c[i]<0 && p[j]<0 && i<nc && j<np) sum+=c[i++]*p[j++];
	i=nc-1;j=np-1; 
	while(c[i]>0 && p[j]>0 && i>=0 && j>=0) sum+=c[i--]*p[j--];
	cout<<sum;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器学习模型机器
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值