1037. Magic Coupon (25)

389 篇文章 1 订阅
140 篇文章 0 订阅

1037. Magic Coupon (25)
时间限制 100 ms 内存限制 65536 kB 代码长度限制 16000 B
判题程序 Standard 作者 CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M )whereanegativevaluecorrespondstoabonusproduct.Youcanapplycoupon3(withNbeing4)toproduct1(withvalueM ) w h e r e a n e g a t i v e v a l u e c o r r e s p o n d s t o a b o n u s p r o d u c t . Y o u c a n a p p l y c o u p o n 3 ( w i t h N b e i n g 4 ) t o p r o d u c t 1 ( w i t h v a l u e M 7) to get M 28back;coupon2toproduct2togetM 28 b a c k ; c o u p o n 2 t o p r o d u c t 2 t o g e t M 12 back; and coupon 4 to product 4 to get M 3back.Ontheotherhand,ifyouapplycoupon3toproduct4,youwillhavetopayM 3 b a c k . O n t h e o t h e r h a n d , i f y o u a p p l y c o u p o n 3 t o p r o d u c t 4 , y o u w i l l h a v e t o p a y M 12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <cstring>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;

const int MaxN = 100010;


bool cmp(int a, int b)
{
    return a > b;
}

int main()
{
#ifdef _DEBUG
    freopen("data.txt", "r+", stdin);
    //fstream cin("data.txt");
#endif // _DEBUG

    int coupons[MaxN], product[MaxN], NC, NP;
    long long Money = 0;

    scanf("%d", &NC);
    for (int i = 0; i < NC; ++i)
        scanf("%d", &coupons[i]);

    scanf("%d", &NP);
    for (int i = 0; i < NP; ++i)
        scanf("%d", &product[i]);

    sort(coupons, coupons + NC, cmp);
    sort(product, product + NP, cmp);

    for (int i = 0; coupons[i] > 0 && product[i] > 0 && i<NP && i<NC; ++i)
        Money += coupons[i] * product[i];

    for(int i = NC-1,j=NP-1; coupons[i] < 0 && product[j] < 0 && i>=0 && j>=0;--i,--j)
        Money += coupons[i] * product[j];

    printf("%lld", Money);


#ifdef _DEBUG
    //cin.close();
#ifndef _CODEBLOCKS
    std::system("pause");
#endif // !_CODEBLOCKS
#endif // _DEBUG

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值