甲级PAT 1040 Longest Symmetric String (25 分)(贪心)

1040 Longest Symmetric String (25 分)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

题目要求: 

找出一个字符串里对称的最长字串的长度。

解题思路:

对称有两种对称,一种是121这样的奇数对称。一种是1221这样的偶数对称。对下标为i的字符,有3中对称方式,一种是和左边字符i-1形成的对称,一种是和右边字符形成i+1的对称,还有一种是以自己为中心,向两边形成的对称(i-1,i+1)。

而和左边字符i-1形成的对称跟左边字符i-1和右边字符(i-1+1=i)是一样的,所以就只有两种对称情况。

判断对称情况只要确定两个开始的下标,依次向左向右展开。

因为只有1000个字符,循环遍历一遍就好了。

完整代码:

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
char s[1010];
int maxlen = 1;
int slen;

void f(int l,int r,int len){
	while(l>=0 && r>=0){
		if(s[l] != s[r]) break;
		else {
			l--;
			r++;
			len+=2;
		}
	}
	if(len > maxlen) maxlen = len;
}

int main(){
	int i,len,l,r;
	fgets(s,1010,stdin);
	slen = strlen(s) - 1;
	for(i=0;i<slen;i++){
		if(i!=slen -1){
			f(i,i+1,0);
			if(i!=0){
				f(i-1,i+1,1);
			}
		}	
	}
	cout<<maxlen<<endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值