PAT甲级- 1040 Longest Symmetric String (25 分)

40 篇文章 0 订阅
29 篇文章 0 订阅

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

dp解决回文串问题。

使用子串长度L作为递增量,左边界i ,右边界i + L - 1,保证dp枚举顺序是合理的。

读入一行字符串 getline(cin, string)

#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
using namespace std;
const int maxn = 1010;
string S;
char dp[maxn][maxn];

int main(){
    //dp[i][j]表示i到j之间的元素是否是回文子串
    getline(cin, S);
    int len = S.length();
    memset(dp, 0, sizeof(dp));
    int max = 1;
    for(int i = 0; i < len; i++){
        dp[i][i] = 1;
        if(i < len - 1 && S[i]==S[i + 1]){
            dp[i][i+1] = 1;
            max = 2; // important
        }
    }

    for(int L = 3; L <= len; L++){
        for(int i = 0; i + L - 1 < len; i++){
            int j = L - 1 + i;
            if(S[i] == S[j] && dp[i+1][j-1] == 1)
            {
                dp[i][j] = 1;
                max = L;
            }

        }
    }

    cout<<max;
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值