甲级PAT 1044 Shopping in Mars (25 分)(连续子序列)

1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题目要求:

给出N个数的序列,找出序列中连续序列的和为M的子序列。

如果没有子序列和为M,则找到大于M的最小值的子序列和对应的序列

解题思路: 

这里想到了之前有做过一个动态规划的题目,就是用一个数组dp[i]存放从起始下标1到下标i的所有元素之和

此时,所有的连续子序列的和都可以用dp[j] - dp[i] (j > i)得到。比如对于一个元素a[i]可以用dp[i] - dp[i-1]得到。

而且由于给出序列里的数都是正数,因此dp[i] 从1 -N 是一个递增序列。

我们要做的就是在这个递增序列中找到dp[j] - dp[i] == M的值,所以可以利用二分法去快速的找到合适的i。

但是要注意,由于有可能并不存在满足M值的子序列,因此需要通知大于M的最小值的子序列和。记录这个值minsum。

因为我是用两个vector来配对满足条件的下标。v1用于存放起始下标,v2用于存放结束下标。

如果经过一次找满足和为M的子序列之后,vector中没有元素,那么就说明不存在满足和为M的子序列。这样就可以用先前记录的minsum再找一遍满足条件的子序列。最后将起始下标和结束下标输出。

注意:

1.当序列中只有一个元素的时候需要单独处理。因为此时的dp[j] - dp[i]实际上i == j所以所得的结果为0,没有结果,测试点4会报错。

2.这里M的范围是10^8,因此不能用int型来存储,需要用long long

3.当dp[k] == M的时候,起始下标是1,结束下标是k,当dp[j] - dp[i] == M的时候,起始下标是i,结束下标是j。

完整代码:

#include<iostream>
#include<vector> 
#include<cstring>
using namespace std;
int a[100010], N;
long long dp[100010],minsum = 9999999;
vector<int> v1,v2; //v1用于存放起始下标,v2用于存放结束下标,相对应 

//第一遍找出和为M的连续子序列,同时记录大于M的最小的子序列和minsum。 
//第二遍找出和为minsum的连续子序列
void f(long long M){
	int i,k,l,r,mid;
	long long sum;
	k = 1;
	while(dp[k] < M) k++;
	for(; k <= N; k++){
		if(dp[k] == M){
			v1.push_back(1);
			v2.push_back(k);
		}else{
			l = 1;
			r = k;
			while(l <= r){
				mid = (l + r) / 2;
				sum = dp[k] - dp[mid];
				if(sum == M){
					v1.push_back(mid+1);
					v2.push_back(k);
					break;
				}
				else if(sum > M){
					if(sum < minsum){  
						minsum = sum;
					}
					l = mid + 1;
				} 
				else r = mid - 1;
			}
		}
	}
}
int main(){
	int i,num;
	long long M;
	memset(dp,0,sizeof(dp));
	scanf("%d %lld",&N,&M);
	for(i = 1; i <= N; i++){
		scanf("%d",&a[i]);
		dp[i] = dp[i-1] + a[i];
	}
	if(N == 1){ //如果序列只有一个元素 
		printf("1-1\n");
	}else{
		f(M);
		num = v1.size();
		if(num == 0){
			f(minsum);	
			num = v1.size();
		}
		for(i = 0; i<num; i++){
			printf("%d-%d\n",v1[i],v2[i]);
		}
	}	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值