PAT甲级 1044 Shopping in Mars(25 分)二分查找

113 篇文章 9 订阅
10 篇文章 0 订阅

1044 Shopping in Mars(25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​), the total number of diamonds on the chain, and M (≤10​8​​), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​⋯D​N​​ (D​i​​≤10​3​​for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + ... + Dj >M with (Di + ... + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题目大意,求一串的数字中连续的一段,使得这个连续的段内数字的和恰好等于所期望的值m。如果不能找到恰好等于,就找让自己付出最少的价格(总和必须大于等于所给值)的那段区间。求所有可能的结果。

解法一:暴力求解,此方法会超时,所以只能得19分。。。

#include<stdio.h>
#include<iostream>
#include<vector>
using namespace std;

int main(){
	int n,m;
	scanf("%d %d",&n,&m);
	vector<int> arr(n+1);
	for(int i=1;i<=n;i++)
		scanf("%d",&arr[i]);
	
	vector<pair<int,int>> res;
	for(int i=1;i<=n;i++){
		int sum = 0;
		for(int j=i;j<=n;j++){
			sum += arr[j];
			if(sum < m)
				continue;
			else if(sum == m){
				res.push_back(pair<int,int>(i,j));
			} 
			else
				break;
		}
	}	
	
	if(res.size() != 0)
	{
		for(auto it:res)
			printf("%d-%d\n",it.first,it.second);
		return 0;	
	}else{
		int min = 9999999;
		for(int i=1;i<=n;i++){
			int sum = 0;
			for(int j=i;j<=n;j++){
				sum += arr[j];
				if(sum < m)
					continue;
				else if(sum > m && min > sum){
					min = sum;
					res.clear();
					res.push_back(pair<int,int>(i,j));
				}
				else if(sum > m && min == sum){
					res.push_back(pair<int,int>(i,j));
				}
			}
		}	
	}
	
	for(auto it:res)
			printf("%d-%d\n",it.first,it.second);	
	
	return 0;
}

解法二:成功AC~~因为sum数组是递增的,所以改用二分法查找~Func函数的作用是二分查找,修改tempsum和j的值~一开始接收输入的时候可以直接保存它的sum函数,即sum[i]表示1~i的所有数字的总和~ 

注意:  fun方法要中vector要用引用,否则会超时!!!

#include<stdio.h>
#include<iostream>
#include<vector>
using namespace std;

int n,m,num;

void fun(vector<int> &arr,int i,int &j,int &tempsum){
	int left = i,right = n;
	while(left < right){
		int mid = (left + right)/2;
		if(arr[mid] - arr[i-1] >= m){
			right = mid;//因为要保证大于等于m,所以不能是right = mid-1 
		}else
			left = mid + 1;
	}
	j = right;
	tempsum = arr[j] - arr[i-1];
}

int main(){
	
	scanf("%d %d",&n,&m);
	vector<int> sum(n+1,0);
	for(int i=1;i<=n;i++){
		scanf("%d",&num);
		sum[i] = sum[i-1] + num;
	} 
		
	vector<int> res;
	int minres = sum[n];//最小值要定义在外面,并且只能是arr[n] 
	for(int i=1;i<=n;i++){
		int j,tempsum;
		fun(sum,i,j,tempsum);
		if(tempsum > minres)continue;
		if(tempsum >= m){
			if(tempsum < minres){
				res.clear();
				minres = tempsum;
			}
			res.push_back(i);
			res.push_back(j);
		}
	}
	
	for(int i = 0; i < res.size(); i += 2)
    	printf("%d-%d\n", res[i], res[i+1]);
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值