** 甲级PAT 1065 A+B and C (64bit) (利用溢出比较大小)

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2​^63​​,2^​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

题目要求:

输入n行数据,每行包括A,B,C。对于第i行数据,如果A+B>C则输出Case #i: true,否则输出Case #i: false

解题思路:

这里要注意 A, B,C的范围是 [−2​^63​​,2^​63​​],而long long所能存储的范围是[−2​^63​​,2^​63-1​​],所能表示的A+B最大的值是2*(2^63-1)=2^64-2

算法笔记中的解释:(有待验证)

注意:

除了这两点,还有一个要注意就是两个负数相加的时候,结果需要大于等于,否则最后一个测试点会报错。

完整代码:

#include<bits/stdc++.h>
using namespace std;

int main(){
	long long a,b,c,r;
	int n,i;
	cin>>n;
	for(i=1;i<=n;i++){
		string result="false";
		cin>>a>>b>>c;
		r=a+b;
		if(a>0&&b>0&&r<0) result="true";
		else if(a<0&&b<0&&r>=0) result="false";
		else if(r>c) result="true";
		cout<<"Case #"<<i<<": "<<result<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值