Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.
Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤109) is the parameter. In the second line there are N positive integers, each is no greater than 109.
Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
结尾无空行
Sample Output:
8
结尾无空行
/*思路:排序之后,使用upper_bound(找到容器内第一个大于指定值的数字位置)
函数,得区域最长长度,最后取最大值*/
#include <bits/stdc++.h>
using namespace std;
int main()
{
int n,p,ans=0;
scanf("%d %d",&n,&p);
vector<int> num(n);
for(int i=0;i<n;i++) scanf("%d",&num[i]);
sort(num.begin(),num.end());
for(int i=0;i<num.size();i++)
{
int j=upper_bound(num.begin(),num.end(),(long long)num[i]*p)-num.begin();
ans=max(ans,j-i);
}
printf("%d\n",ans);
return 0;
}