BestCoder Round #84 1002 Bellovin


Problem Description
Peter has a sequence a1,a2,...,an and he define a function on the sequence -- F(a1,a2,...,an)=(f1,f2,...,fn) , where fi is the length of the longest increasing subsequence ending with ai .

Peter would like to find another sequence b1,b2,...,bn in such a manner that F(a1,a2,...,an) equals to F(b1,b2,...,bn) . Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence a1,a2,...,an is lexicographically smaller than sequence b1,b2,...,bn , if there is such number i from 1 to n , that ak=bk for 1k<i and ai<bi .
 

Input
There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:

The first contains an integer n (1n100000) -- the length of the sequence. The second line contains n integers a1,a2,...,an (1ai109) .
 

Output
For each test case, output n integers b1,b2,...,bn (1bi109) denoting the lexicographically smallest sequence.
 

Sample Input
  
  
3 1 10 5 5 4 3 2 1 3 1 3 5
 

Sample Output
  
  
1 1 1 1 1 1 1 2 3



题意: 给一个序列,让换成另一个序列,满足每一位都和原序列的最长上升子序列位数相同,其实就是求每一位的最长上升子序列个数;不能用DP,用nlog(n),不然超时;


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>

using namespace std;

int dp[100000 + 5];
int b[100000 + 5];

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n, temp;
        cin>>n;
        dp[0] = 0;
        b[0] = 0;
        for(int i = 1, j = 0; i <= n; i++)
        {
            cin>>temp;
            if(temp>dp[j])                    //大于最后一位数直接放最后;
            {
                dp[++j] = temp;         
                b[i] = j;
            }
            else
            {
                int add = lower_bound(dp+1,dp+j+1,temp)-dp;          //否则查找到然后替换前面的
                dp[add] = temp;
                b[i] = add;
            }
        }
        cout<<b[1];
        for(int i = 2; i <= n; i++)
            cout<<" "<<b[i];
        cout<<endl;

    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值