《ACM程序设计》书中题目Y(几个几@v@~~)

Description

The look and say sequence is defined as follows. Start with any string of digits as the first element in the sequence. Each subsequent element is defined from the previous one by "verbally" describing the previous element. For example, the string 122344111 can be described as "one 1, two 2's, one 3, two 4's, three 1's". Therefore, the element that comes after 122344111 in the sequence is 1122132431. Similarly, the string 101 comes after 1111111111. Notice that it is generally not possible to uniquely identify the previous element of a particular element. For example, a string of 112213243 1's also yields 1122132431 as the next element.

Input

The input consists of a number of cases. The first line gives the number of cases to follow. Each case consists of a line of up to 1000 digits.

Output

For each test case, print the string that follows the given string.

Sample Input



3
122344111
1111111111
12345

Sample Output



1122132431
101
1112131415


这道题就是读取一串数字,连续的几个数字就用ab(连续的a个b)描述;

思路如下:

1.利用字符数组存数字;

2.输入后逐个检查,遇到数字变化便输出一次“ab”;


程序如下:

#include<bits/stdc++.h>
using namespace std;
int main()
{
        char num[1005],x;
        int i,j,n,t;
        cin>>n;
        for(i=0;i<n;i++)
        {
                t=0;
                memset(num,0,1004);       //一次输入输出完成后计数器和字符串归零
                cin>>num;
                x=num[0];
                for(j=0;j<=strlen(num);j++)
                {
                        if(x==num[j])       //相同数字计数器加一
                        {
                                t++;
                        }
                        else
                        {
                                cout<<t<<num[j-1];            //数字不同输出,计数器归一(因为这一次数字被判定掉了)
                                t=1;
                                x=num[j];
                        }
                }
                cout<<endl;
        }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值