女生赛hdu6025

Do you know what is called ``Coprime Sequence''? That is a sequence consists of  n  positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
 

Input
The first line of the input contains an integer  T(1T10) , denoting the number of test cases.
In each test case, there is an integer  n(3n100000)  in the first line, denoting the number of integers in the sequence.
Then the following line consists of  n  integers  a1,a2,...,an(1ai109) , denoting the elements in the sequence.
 

Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.
 

Sample Input
  
  
3 3 1 1 1 5 2 2 2 3 2 4 1 2 4 8
 

Sample Output
  
  
1 2 2
 

Source
看数据 10w个而已 O(N)肯定可以过,每次枚举每一个点就可以了他的左右两遍就就是删去当前点剩下的gcd值,这题是被简化的。
#include<iostream>
#include<cstdio>
using namespace std;
int gcd(int a,int b){
	return b==0? a:gcd(b,a%b);
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n;
		scanf("%d",&n);
		int a[100005],l[100005],r[100005];
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
		}
		l[0]=a[0];
		r[n-1]=a[n-1];
		for(int i=1;i<n;i++){
			l[i]=gcd(l[i-1],a[i]);
		}
		for(int i=n-2;i>=0;i--){
			r[i]=gcd(r[i+1],a[i]);
		}
		int ans = 0;
		if(ans<r[1]){
				ans=r[1];
			}
		if(ans<l[n-2])ans=l[n-2];
		for(int i=1;i<n-1;i++){
		 	if(ans<gcd(l[i-1],r[i+1])){
		 		ans = gcd(l[i-1],r[i+1]); 
			 }
		}
		printf("%d\n",ans);
	}
}
int gcd(int a,int b){
	return b==0? a:gcd(b,a%b);
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n;
		scanf("%d",&n);
		int a[100005],l[100005],r[100005];
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
		}
		l[0]=a[0];
		r[n-1]=a[n-1];
		for(int i=1;i<n;i++){
			l[i]=gcd(l[i-1],a[i]);
		}
		for(int i=n-2;i>=0;i--){
			r[i]=gcd(r[i+1],a[i]);
		}
		int ans = 0;
		if(ans<r[1]){
				ans=r[1];
			}
		if(ans<l[n-2])ans=l[n-2];
		for(int i=1;i<n-1;i++){
		 	if(ans<gcd(l[i-1],r[i+1])){
		 		ans = gcd(l[i-1],r[i+1]); 
			 }
		}
		printf("%d\n",ans);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值