hdu6025

Do you know what is called Coprime Sequence''? That is a sequence consists of n positive integers, and the GCD (Greatest Common Divisor) of them is equal to 1.Coprime Sequence’’ is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.
Input
The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.
In each test case, there is an integer n(3≤n≤100000) in the first line, denoting the number of integers in the sequence.
Then the following line consists of n integers a1,a2,…,an(1≤ai≤109)
, denoting the elements in the sequence.
Output
For each test case, print a single line containing a single integer, denoting the maximum GCD.
Sample Input

3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8

Sample Output

1
2
2
思路:用辗转相除法求出前缀gcd和后缀gcd,再枚举删掉的每一种情况,求最大值。
    #include<stdio.h>
#include<algorithm>
#define N 100010
using namespace std;
int gcd(int a,int b)
{
    while(b!=0)
    {
        int c=a%b;
            a=b;
            b=c;
    }
    return a;
}
int main()
{
    int T,n,i,j,a[N],fro[N],beh[N],ans;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        fro[0]=a[0];
        for(i=1;i<n;i++)
        {
            fro[i]=gcd(fro[i-1],a[i]);//求前缀GCD
        }
        beh[n-1]=a[n-1];
        for(i=n-2;i>=0;i--)
        {
            beh[i]=gcd(beh[i+1],a[i]);//求后缀GCD
        }
        ans=0;
        for(i=0;i<n;i++)//除掉a[i]后其他数GCD的值  找最大
        {
            if(i==0)
                ans=max(ans,beh[1]);
            else if(i==n-1)
                ans=max(ans,fro[n-2]);
            else
                ans=max(ans,gcd(fro[i-1],beh[i+1]));
        }
        printf("%d\n",ans);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值