zoj1700 Falling Leaves

Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem.

A binary tree of letters may be one of two things:

It may be empty.

It may have a root node. A node has a letter as data and refers to a left and a right subtree. The left and right subtrees are also binary trees of letters.

In the graphical representation of a binary tree of letters:

Empty trees are omitted completely.

Each node is indicated by
> Its letter data,
> A line segment down to the left to the left subtree, if the left subtree is nonempty,
> A line segment down to the right to the right subtree, if the right subtree is nonempty.

A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y.

The preorder traversal of a tree of letters satisfies the defining properties:

If the tree is empty, then the preorder traversal is empty.

If the tree is not empty, then the preorder traversal consists of the following, in order

> The data from the root node,
> The preorder traversal of the root's left subtree,
> The preorder traversal of the root's right subtree.

The preorder traversal of the tree in Figure 1 is KGCBDHQMPY.

A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies:

The root's data comes later in the alphabet than all the data in the nodes in the left subtree.

The root's data comes earlier in the alphabet than all the data in the nodes in the right subtree.

The problem:

Consider the following sequence of operations on a binary search tree of letters

Remove the leaves and list the data removed
Repeat this procedure until the tree is empty
Starting from the tree below on the left, we produce the sequence of trees shown, and then the empty tree

by removing the leaves with data

BDHPY
CM
GQ
K

Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree.


Input

The input file will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters.

The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk ('*').

The last data set is followed by a line containing only a dollar sign ("$"). There are no blanks or empty lines in the input.

Output

For each input dataset, there is a unique binary search tree that would produce these quence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.

Sample Input

BDHPY

CM

GQ

K

*

AC

B

$


Sample Output

KGCBDHQMPY
BAC

Analysis:

1. Firstly, we should understand the meaning of problem, it asks us for getting a postorder traversal of the search tree.

2. So, how can we get this tree? There are two ways to solve this problem. One is getting the postorder traversal by the rule of input string. Another is building a tree first.

3. Obviously, building a tree first is an easier way to getting the result. So how can I use the input string to build tree?

4. We observe that the latter is closer to the root of tree, so we can firstly stitch the strings together and then insert them one by one backwards to get the target search tree.

5. At this point, we can solve this problem clearly.

#include <iostream>
using namespace std;

struct node
{
    char data;
    node *child[2];
    node(char d)
    {
        data = d;
        child[0] = NULL; //must be careful not to write ==
        child[1] = NULL;
    }
};

void insert(node *&r, char ch) //recursion are to use the reference method, to pass the value obtained back to the pre-function
{
    if (r == NULL)
    {
        node *p = new node(ch); //create new node
        r = p;
        return;
    }
    else if (ch > r->data) insert(r->child[1], ch);
    else if (ch < r->data) insert(r->child[0], ch);
}

void Preorder(node *root) //preorder traversal
{
    if (root)
    {
        cout << root->data;
        Preorder(root->child[0]);
        Preorder(root->child[1]);
    }
}

int main()
{
    string str = "";
    string s = ""; //Spliced string
    node *root = NULL;
    while (cin >> str)
    {
        if (str[0] == '*' || str[0] == '$')
        {
            //Insert into the search tree in reverse order
            for (int i = s.length() - 1; i >= 0; i--)
            {
                insert(root, s[i]);
            }
            //Output a tree with preorder traversal
            Preorder(root);
            cout<<endl;
            if (str[0] == '$')
                return 0;
            //To re-initialize if not yet finished
            root = NULL;
            s = "";
            str = "";
        }
        //String Splicing
        s += str;
    }
    return 0;
}

Conclusion:
For this question, the direction of thinking is particularly important. However, the basic idea should follow the conventional approach. If the tree is built by insertion, then we should think about how to insert to get the target search tree, not about string rules.

Stuck points:

I wonder if I should get the post-order traversal by building a tree. And don't know how to build a tree.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值