PAT (Advanced Level) 刷题记录 1046 Shortest Distance (20分)

1046 Shortest Distance (20分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^​5 ]), followed by N integer distances D​1 D​2 ⋯ D​N, where D​i is the distance between the i-th and the (i+1)-st exits, and D​Nis between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10^4), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^​7
​​ .

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

总结:
这题用暴力解法的话,最后一个测试点会超时。
参考 1044 Shopping in Mars的思路,可以用sum的数组来保存1到该节点的距离,但是不一样的地方是:本题的输入不同,Di是i到i+1之间的距离。所以两点的距离公式是:

int x = sum[e - 1] - sum[s - 1];//e是目的节点,s是起始节点

下面分别给出暴力解法和累加数组的解法:
暴力解法:

//普通遍历运行超时
#include <iostream>
#include<iomanip>
#include<algorithm>
#include<string>
#include <vector>
#include<map>
#include <queue>
#include<math.h>
using namespace std;
int a[100001];
int main() {
	//#ifdef ONLINE_JUDGE
	//#else
	//	freopen("1.txt", "r", stdin);
	//#endif // ONLINE_JUDGE
	int n;
	cin >> n;
	int sum = 0;
	for (int i = 1; i <= n; i++) {
		int temp;
		scanf("%d", &temp);
		a[i] = temp;
		sum += temp;
	}
	int m=0;
	cin >> m;
	for (int i = 0; i < m; i++) {
		int s, e;
		scanf("%d %d", &s, &e);
		if (s > e)
			swap(s, e);
		int x = 0;
		for (int j = s; j < e; j++) {
			x += a[j];
		}
		if (x < sum - x) {
			printf("%d\n", x);
		}
		else {
			printf("%d\n", sum - x);
		}
	}
}

改进法:

/*可以用累加数组*/
#include <iostream>
#include<iomanip>
#include<algorithm>
#include<string>
#include <vector>
#include<map>
#include <queue>
#include<math.h>
using namespace std;
int sum[100001];
int main() {
	//#ifdef ONLINE_JUDGE
	//#else
	//	freopen("1.txt", "r", stdin);
	//#endif // ONLINE_JUDGE
	int n;
	cin >> n;
	sum[0] = 0;
	for (int i = 1; i <= n; i++) {
		int temp;
		scanf("%d", &temp);
		sum[i] = temp;
		sum[i] += sum[i-1];
	}
	int m = 0;
	cin >> m;
	for (int i = 0; i < m; i++) {
		int s, e;
		scanf("%d %d", &s, &e);
		if (s > e)
			swap(s, e);
		int x = sum[e - 1] - sum[s - 1];//关键步骤
		if (x < sum[n] - x) {
			printf("%d\n", x);
		}
		else {
			printf("%d\n", sum[n] - x);
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值