PAT (Advanced Level) 刷题记录 1075 PAT Judge (25分)

1075 PAT Judge (25分)

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10^4), the total number of users, K (≤5), the total number of problems, and M (≤10^​5), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

这个题目主要是要求比较多,需要考虑得很细。主要的难点有:
1.得出满分的个数(排序需要),需防止重复计数。
2.只要提交了,不管编译通没通过,分数都置为0
3.没提交过的 或者 提交过但是编译都没有通过 这两种情况不予以输出。

#include<iostream>
#include<string>
#include<vector>
#include<map>
#include <queue>
#include<algorithm>
using namespace std;
int N, K, M;
struct Node {
	int id=999999;
	int grade[6] = { -1,-1,-1,-1,-1,-1 };
	int sum = 0;
	int perfrctnum = 0;
	int flag = 0;
};
int p[6];
Node stu[10001];
bool cmp(Node& a, Node& b) {
	if (a.sum != b.sum)
		return a.sum > b.sum;
	else if (a.perfrctnum != b.perfrctnum)
		return a.perfrctnum > b.perfrctnum;
	else {
		return a.id < b.id;
	}
}
int main() {
	cin >> N >> K >> M;
	for (int i = 1; i <= K; i++) {
		cin >> p[i];
	}
	for (int i = 0; i < M; i++) {
		int id, qnum, grade;
		cin >> id >> qnum >> grade;
		stu[id].id = id;
		if (grade == -1) {//编译没通过
			if (stu[id].grade[qnum] <= 0)//后来编译未通过的不能把之前的成绩抹掉,这是最后一个算法没有通过的第一个点
				stu[id].grade[qnum] = 0;
		}
		else {//编译通过
			stu[id].flag = 1;
			if (grade == p[qnum] && stu[id].grade[qnum] != p[qnum]) {//满分情况,且之前未拿过满分
				stu[id].perfrctnum++;
			}
			if (grade > stu[id].grade[qnum]) {//如果比当前成绩好
				if (stu[id].grade[qnum] == -1) {//之前未提交过
					stu[id].grade[qnum] = grade;
					stu[id].sum += grade;
				}
				else {//提交过了,sum应该先减去之前的分数
					stu[id].sum = stu[id].sum - stu[id].grade[qnum] + grade;
					stu[id].grade[qnum] = grade;
				}
			}
		}
	}
	sort(stu + 1, stu + N + 1, cmp);
	int rank = 0;
	/*这是最后一个算法没有通过的第二个点:
  第二个点是:排序后,排在最后的没有提交过的和提交过但是他们的总分是一样的,是零的。
  但是我们需要输出分数是flag==1的,
  这时候if (stu[i].sum != stu[i-1].sum)这句话就有问题 
  我本来的意思是只要跟上一位不一样,就以当前的位置i作为他的排名,碰到上述这种情况,排名就会出错。
  解决方案是
  1.给id付个初值999999,这样cmp就会直接将未提交过的排到后面去,前面的都是提交过的。这种方法有个问题,具体问题在下方。
  2.只要在cmp函数中加上对flag的判断即可。其他的不用改动,因为可以保证所有需要输出全在函数前端,只要碰到flag==0的直接退出循环即可。修正后的cmp函数也在最后给出。
  */
	for (int i = 1; i <= N; i++) {
		if (!stu[i].flag) {
			continue;
		}
		if (stu[i].sum != stu[i-1].sum) {
			printf("%d %05d %d", i, stu[i].id, stu[i].sum);
			rank = i;
			for (int j = 1; j <= K; j++) {
				stu[i].grade[j] == -1 ? cout << " -" : cout << " " << stu[i].grade[j];
			}
			cout << endl;
		}
		else {
			printf("%d %05d %d", rank, stu[i].id, stu[i].sum);
			for (int j = 1; j <= K; j++) {
				stu[i].grade[j] == -1 ? cout << " -" : cout << " " << stu[i].grade[j];
			}
			cout << endl;
		}
	}
}

解决方案1问题:
比如说00006提交过但是编译都没有通过,应该不予以输出,00008提交的都是零,应该输出,如下方测试用例,

 8 4 25
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
00006 1 -1
00008 1 0
00008 2 0
00008 3 0
00008 4 0 

正确输出应该是

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
6 00008 0 0 0 0 0

但是代码输出是

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
7 00008 0 0 0 0 0 

00008的排名有问题
但是能勉强过最后一个测试用例,运气比较好,可能PAT最后没有检测出这个问题。
后来发现不需要这么麻烦,只需要在cmp函数中加上一个对flag 的排序即可。
修正后的cmp函数

 bool cmp(Node& a, Node& b) {
	if (a.sum != b.sum)
		return a.sum > b.sum;
	else if (a.perfrctnum != b.perfrctnum)
		return a.perfrctnum > b.perfrctnum;
	else if(a.flag!=b.flag)//加了这个
		return a.flag > b.flag;
	else
		return a.id < b.id;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值