HDU 1087 条件记忆化搜索


     
一道记忆化搜索的经典题,特费脑子,因为我搜索本来就学的不太好,以后还要多做题:


上原题:

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2829    Accepted Submission(s): 1098


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 

 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's.
 

 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 

 

Sample Input
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

 

Sample Output
37
 

思路:U

 我刚开始跟点击打开链接这个大神一样的,我以为走k步可以随便走,后来才知道只能水平垂直一个方向走,每一步的方向都是一样的,horizontally or vertically(水平跟垂直),然后就是记忆化搜索了,但每走一步,下一步能吃到的cheese必须比当前的大,刚

开始我是把这个判断放在DFS内部的,不符合条件就return,其实放在对下一步进行DFS的

情况排除时更好,还能节约时间,然后具体的记忆化搜索就没法讲了,我自己都还要琢磨。


/*
「“04.24,サクラと东京スカイツリーに行った。そこは世界で一番暖かいところだ。”
“04.26,サクラと明治神宫に行った。そこで结婚式お挙げる人がいた。”
“04.25,サクラとデイズニーに行った。お化け屋敷が怖かったけど、サクラがいたから、全然怖くわなかった。”
“サクラのことが大好き。”」
*/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include <iostream>
#include <algorithm>
using namespace std;
int a[101][101],dp[101][101];
int n,k;
int DFS(int x,int y)
{
    if(dp[x][y])
         return dp[x][y];
    int temp=0;
    for(int i=x-k;i<=x+k;i++)
    {
        if(i<0||i>=n)
            continue;
        if(i!=x)
        {
            if(a[i][y]>a[x][y])
                temp=max(temp,DFS(i,y));
        }
    }
    for(int j=y-k;j<=y+k;j++)
    {
        if(j<0||j>=n)
            continue;
        if(j!=y)
        {
            if(a[x][j]>a[x][y])
                temp=max(DFS(x,j),temp);
        }
    }
    dp[x][y]=a[x][y]+temp;
    return dp[x][y];
}
int main()
{
    cin.tie(0);
    cin.sync_with_stdio(false);
   // freopen("in.txt","r",stdin);
    while(cin>>n>>k,n!=-1&&k!=-1)
    {

        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                cin>>a[i][j];
                dp[i][j]=0;
            }
        }
        DFS(0,0);
        cout<<dp[0][0]<<endl;
    }
    return 0;
}

加油!









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值