HDU1069-Monkey and Banana-记忆化搜索

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目大意:

有n种积木,每种积木无限,把一个积木放在另一个积木的上面,建一个塔。
每种积木都是一个具有线性尺寸(xi, yi, zi)的矩形实体。一个物体可以被重新定向,这样它的三个维度中的任意两个都可以作为基座的维度,另一个维度是高度
一个块能被放置在另一个块上的条件是:上层块的两个基座维度都严格小于下层块对应的基座维度(底面相同的块不能堆叠)。
编写程序,确定可以用给定的积木建造的最高塔的高度。

核心思想:

记忆化搜索或动态规划。
每种积木有三种使用方式(三个维度分别当高)。将三种使用方式分别编号0,1,2。
dp[i][j]表示能在第i种积木的第j种使用方式的底面上可以搭建的最高的高度。
状态转移方程见代码。

代码如下:

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
struct node{
	ll a,b,c,v;//a是底面长度,b是底面宽度,c是高度,v是dp值 
}h[44][5];
ll dfs(int k,int z,int n)//记忆化搜索 
{
	if(h[k][z].v!=-1)
		return h[k][z].v;
	ll mx=0;
	//状态转移 
	for(int i=1;i<=n;i++)
		for(int j=0;j<3;j++)
			//上层块的两个基座维度都严格小于下层块对应的基座维度
			if(h[i][j].a<h[k][z].a&&h[i][j].b<h[k][z].b)
				mx=max(mx,dfs(i,j,n));
	return h[k][z].v=mx+h[k][z].c;		
}
int main()
{
	int n,ca=0;
	ll x,y,z;
	while(1)
	{
		scanf("%d",&n);
		if(!n)
			break;
		for(int i=1;i<=n;i++)
		{
			scanf("%lld%lld%lld",&x,&y,&z);
			//x当高 
			h[i][0].a=max(y,z);
			h[i][0].b=min(y,z);
			h[i][0].c=x;
			h[i][0].v=-1;
			//y当高 
			h[i][1].a=max(x,z);
			h[i][1].b=min(x,z);
			h[i][1].c=y;
			h[i][1].v=-1;
			//z当高 
			h[i][2].a=max(x,y);
			h[i][2].b=min(x,y);
			h[i][2].c=z;
			h[i][2].v=-1;
		}
		ll ans=0;
		for(int i=1;i<=n;i++)
			for(int j=0;j<3;j++)
				ans=max(ans,dfs(i,j,n));
		printf("Case %d: maximum height = %lld\n",++ca,ans);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值