POJ1679 The Unique MST(次小生成树)

The Unique MST

Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 25894

 

Accepted: 9256

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source

 

题意:询问最小生成树是否唯一。

思路:求出次小生成树和最小生成树比较,如果大小一样,那么就不唯一。

次小生成树:枚举不在次小生成树上的边,把它加进最小生成树,然后删掉i,j两点(假设新加入的边联通的是i,j两点)间权值最大的边。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define maxn 105
#define inf 999999999
int dp[maxn][maxn], val[maxn][maxn], mincost[maxn], pre[maxn];
bool vis[maxn], used[maxn][maxn];
int MIS, ans, N;
int prim(){
    memset(vis, 0, sizeof vis);
    memset(used, false, sizeof used);
    memset(dp, 0, sizeof dp);

    for(int i = 1;i <= N;i++){
        mincost[i] = val[1][i];
        pre[i] = 1;
    }
    vis[1] = 1;
    int v;
    int res = 0;
    while(true){
        v = -1;
        for(int u = 1;u <= N;u++){
            if(!vis[u]&&(v==-1||mincost[u]<mincost[v])) v = u;
        }

        if(v == -1) break;
        used[v][pre[v]] = used[pre[v]][v] = true;
        vis[v] = 1;
        res += val[v][pre[v]];

        for(int i = 1;i <= N;i++){
            if(vis[i]&&i!=v){
                dp[i][v] = dp[v][i] = max(dp[i][pre[v]], mincost[v]);
            }
            if(!vis[i]&&mincost[i]>val[v][i]){
                mincost[i] = val[v][i];
                pre[i] = v;
            }
        }
    }

    return res;
}
int Unique(){
    int res = inf;
    for(int i = 1;i <= N;i++)
        for(int j = 1;j <= N;j++)
            if(i!=j&&!used[i][j])
                res = min(res, MIS-dp[i][j]+val[i][j]);
    //printf("%d\n", res);
    if(res == inf) return -1;
    return res;
}

int main()
{
    int t, i, j, E, u, v, cost;
    scanf("%d", &t);
    while(t--){
        scanf("%d %d", &N, &E);
        memset(val, 127, sizeof val);
        for(i = 1;i <= E;i++){
            scanf("%d %d %d", &u, &v, &cost);
            val[u][v] = val[v][u] = cost;
        }

        MIS = prim();
        if(MIS==Unique()) printf("Not Unique!\n");
        else printf("%d\n", MIS);
    }
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值