HDU2604 Queuing(矩阵快速幂模板)

Queuing

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4348    Accepted Submission(s): 1925


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time.

  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2 L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.
 

Input
Input a length L (0 <= L <= 10 6) and M.
 

Output
Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.
 

Sample Input
      
      
3 8 4 7 4 8
 

Sample Output
      
      
6 2 1
 

Author
WhereIsHeroFrom
 

Source
 思路:假设L长度的最后一位是m,那么只需要考虑前n-1位满足条件的个数,也就是f(n-1),如果最后一位不是m,再往前考虑一位,
那么最后三位可能是mmf,fmf,fff,mff,其中mmf,mff符合条件,mmf只需要前n-3位满足,mff只有mmff满足,即需要前n-4位满足,也
就是f(n) = f(n-1)+f(n-3)+f(n-4)。按照这样来建立构造矩阵。
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define ll long long int
#define maxn 10
using namespace std;
int L, MOD;
struct node{
    int line, cal;
    ll mxt[maxn][maxn];
    node(){
        memset(mxt, 0, sizeof mxt);
    }
    void init(ll v){
        for(int i = 0;i <= maxn;i++)
            mxt[i][i] = v;
    }
};
node operator * (node a, node b){
    node c;
    c.line = a.line, c.cal = b.cal;
    for(ll i = 0;i < a.line;i++){
        for(ll j = 0;j < b.cal;j++){
            c.mxt[i][j] = 0;
            for(ll k = 0;k < a.cal;k++){
                c.mxt[i][j] += (a.mxt[i][k] * b.mxt[k][j])%MOD;
                c.mxt[i][j] %= MOD;
            }
        }
    }
    return c;
}
node operator ^ (node a, ll n){
    node c;
    c.init(1);
    c.line = a.line, c.cal = a.cal;
    while(n){
        if(n&1) c = a * c;
        a = a * a;
        n >>= 1;
    }
    return c;
}
int main()
{
    node a, b, c;
    a.line = 4, a.cal = 1;
    a.mxt[0][0] = 9, a.mxt[1][0] = 6, a.mxt[2][0] = 4, a.mxt[3][0] = 2;
    b.line = 4, b.cal = 4;
    b.mxt[0][0] = b.mxt[0][2] = b.mxt[0][3] = b.mxt[1][0] = b.mxt[2][1] = b.mxt[3][2] = 1;
    c.line = 4, c.cal = 4;
    while(~scanf("%d %d", &L, &MOD)){
        if(L == 0) printf("0\n");
        else if(L <= 4) printf("%lld\n", a.mxt[4-L][0]%MOD);
        else{
            c = b ^ (L - 4);
            c = c * a;
            printf("%lld\n", c.mxt[0][0]%MOD);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值