poj 3258-River Hopscotch



Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ MN).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source


题目大意:牛跳岩石,给出总长度L,牛的个数N和可以去掉的牛的头数M,求去掉M头牛后,最短距离的最大值。
思路:假设mid是最短距离,count记录此时的mid可以去掉的牛的头数,如果比M小就变大mid,如果比M大就变小mid,注意要求最大值所以等于的时候变大mid。
代码:
import java.util.*;
public class Main {
 public static void main(String[] args) {
  Scanner scan=new Scanner(System.in);
  int L,n,m;
  L=scan.nextInt();
  n=scan.nextInt();
  m=scan.nextInt();
  int a[]=new int[n+2];
  a[0]=0;
  a[n+1]=L;
  int l=0,r=L;
  for(int i=1;i<=n;i++){
   a[i]=scan.nextInt();
  }
  Arrays.sort(a,0,n+2);
  for(int i=1;i<=n+1;i++){
   if(l>a[i]-a[i-1])
    l=a[i]-a[i-1];
  }
  while(l<=r){
   int mid=(l+r)/2;
   int sum=0;
   int count=0;
   for(int i=1;i<=n+1;i++){
    sum+=a[i]-a[i-1];
    if(sum<=mid){
     count++;
    }
    else{
     sum=0;
    }
   }
   if(count<=m){
    l=mid+1;
   }
   else
    r=mid-1;
  }
  System.out.println(l);
 }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值