hdu5360 Hiking

Problem Description
There are  n  soda conveniently labeled by  1,2,,n . beta, their best friends, wants to invite some soda to go hiking. The  i -th soda will go hiking if the total number of soda that go hiking except him is no less than  li  and no larger than  ri . beta will follow the rules below to invite soda one by one:
1. he selects a soda not invited before;
2. he tells soda the number of soda who agree to go hiking by now;
3. soda will agree or disagree according to the number he hears.

Note: beta will always tell the truth and soda will agree if and only if the number he hears is no less than  li  and no larger than  ri , otherwise he will disagree. Once soda agrees to go hiking he will not regret even if the final total number fails to meet some soda's will.

Help beta design an invitation order that the number of soda who agree to go hiking is maximum.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains an integer  n   (1n105) , the number of soda. The second line constains  n  integers  l1,l2,,ln . The third line constains  n  integers  r1,r2,,rn (0lirin)
It is guaranteed that the total number of soda in the input doesn't exceed 1000000. The number of test cases in the input doesn't exceed 600.
 

Output
For each test case, output the maximum number of soda. Then in the second line output a permutation of  1,2,,n  denoting the invitation order. If there are multiple solutions, print any of them.
 

Sample Input
  
  
4 8 4 1 3 2 2 1 0 3 5 3 6 4 2 1 7 6 8 3 3 2 0 5 0 3 6 4 5 2 7 7 6 7 6 8 2 2 3 3 3 0 0 2 7 4 3 6 3 2 2 5 8 5 6 5 3 3 1 2 4 6 7 7 6 5 4 3 5
 

Sample Output
  
  
7 1 7 6 5 2 4 3 8 8 4 6 3 1 2 5 8 7 7 3 6 7 1 5 2 8 4 0 1 2 3 4 5 6 7 8

这题可以用集合做,也可以用优先队列做,方法差不多,可以把所有的元素用线段表示,然后从0开始每次找左边界l[i]小于等于当前集合人数的元素,然后把它放进集合(或优先队列)中,然后删掉右边界r[i]不符合条件的元素(即右边界小于当前元素,这里不用考虑左边界了,因为在集合中的元素一定是l[i]<=tot才放进来的,只要考虑右边界就行了)。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
#define maxn 100060
struct node{
	int l,r,idx;
}a[maxn],temp;
int vis[maxn],c[maxn];

bool operator <(node a,node b){
	return a.r>b.r;
}
priority_queue<node> q;

bool cmp(node a,node b){
	if(a.l==b.l)return a.r<b.r;
	return a.l<b.l;
}

int main()
{
	int n,m,i,j,T,tot,num1;
	scanf("%d",&T);
	while(T--)
	{
		while(!q.empty())q.pop();
		memset(vis,0,sizeof(vis));
		scanf("%d",&n);
		for(i=1;i<=n;i++){
			scanf("%d",&a[i].l);
			a[i].idx=i;
		}
		for(i=1;i<=n;i++){
			scanf("%d",&a[i].r);
		}
		sort(a+1,a+n+1,cmp);
		if(a[1].l!=0){
			printf("0\n");
			for(i=1;i<=n;i++){
				if(i==n)printf("%d\n",i);
				else printf("%d ",i);
			}
			continue;
		}
		tot=0;num1=1;
		while(1)
		{
			while(a[num1].l<=tot && num1<=n){
				q.push(a[num1]);num1++;
			}
			while(!q.empty()){
				temp=q.top();
				if(temp.r<tot){
					q.pop();
				}
				else break;
			}
			if(q.empty())break;
			temp=q.top();
			tot++;c[tot]=temp.idx;vis[temp.idx]=1;
			q.pop();
		}
		printf("%d\n",tot);
		for(i=1;i<=n;i++){
			if(vis[i])continue;
			c[++tot]=i;
		}
		for(i=1;i<=tot;i++){
			if(i==tot)printf("%d\n",c[tot]);
			else printf("%d ",c[i]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值