Hdu5317 RGCDQ

Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know maxGCD(F(i),F(j)) (Li<jR)
 

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
 

Output
For each query,output the answer in a single line.
See the sample for more details.
 

Sample Input
2
2 3
3 5
 

Sample Output
1
1

Author
ZSTU、
首先是预处理,计算出每个数i的F(i);
我是采用了筛法,当遇到素数时,它和它的倍数的F值均加1,这样就得到了所有数的F值;
在求从2到1000000每个数对应的F(i)个数,记录在ans[maxn][10]中;
(取十是因为2*3*5*7*11*13*17<1000000而2*3*5*7*11*13*17*19>1000000)
对于区间[l,r],求区间内各值的个数即可,用a[i]去记录;
接下来,若当i>2时,如果a[i]>1,那么最大的i即为所求;
否则,考虑2,4,6以及3,6,看这些数的a[i]之和是否大于1即可;
(网上的版本用了循环和gcd函数,个人认为数据小时还是我的方法好)
若之和均不大于1,那么答案为1。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#define LL long long
#define maxn 1000001
using namespace std;
int v[maxn];
int ans[maxn][10];
void p()
{
    int i,j,n=maxn,m;
    m=(int)sqrt(n+0.5);
    memset(v,0,sizeof(v));
    memset(ans,0,sizeof(ans));
    for(i=2;i<n;++i){
        if(v[i]==0){
            for(j=i;j<n;j+=i)
                v[j]++;
        }
    }
    for(i=2;i<n;++i){
        for(j=2;j<=7;++j){
            ans[i][j]=ans[i-1][j];
        }
        ans[i][v[i]]++;
    }
}
int main()
{
    int t,l,r,i,s;
    int a[10];
    p();
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&l,&r);
        s=10;
        for(i=2;i<=7;++i){
            a[i]=ans[r][i]-ans[l-1][i];
            if(a[i]>1) s=i;
        }
        if(s==10){
            if(a[3]+a[6]>1) s=3;
            else if(a[2]+a[4]+a[6]>1) s=2;
            else s=1;
        }
        printf("%d\n",s);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值