hdu 5317 RGCDQ(数论素筛)

RGCDQ
Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know  maxGCD(F(i),F(j))   (Li<jR)
 

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
 

Output
For each query,output the answer in a single line. 
See the sample for more details.
 

Sample Input
   
   
2 2 3 3 5
 

Sample Output
   
   
1 1
 

Author
ZSTU
 

Source



ps:
一看题意如果按照常规方法写的话,就肯定会超时的,所以我们可以先对f[i]打个表,观察一下它的规律

我们可以发现2*3*5*7*11*13*17=510510,2*3*5*7*11*13*17*19=9699690,也就是说100w以内的数的素因数种类最多为7

因此,我们可以先预处理打表,在素数筛法的过程中,让a[i]表示i的素因子种类数,让b[i][j]表示2到i中素因子种类数为j的有多少个

打完表后就可以让i从7到1开始遍历,只要有b[R][i]-b[L-1][i]>=2(就说明在L~R区间内素因子种类数为i的数至少有两个),就令ans=i,并且break输出即可(因为我们要的是最大值)

代码:
#include<stdio.h>
#include<string.h>

#define maxn 1000000+10
int a[maxn],b[maxn][8];

void pre_table()
{
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    for(int i=2; i<maxn; i++)
    {
        if(!a[i])
            for(int j=i+i; j<maxn; j+=i)
                a[j]++;
    }
    for(int i=2;i<maxn;i++)
        for(int j=1;j<=7;j++)
    {
        b[i][j]=b[i-1][j];
        if(a[i]==j)
            b[i][j]++;
    }
}

int main()
{
    pre_table();
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int L,R;
        scanf("%d%d",&L,&R);
        int ans=1;
        for(int i=7;i>=1;i--)
        {
            if(b[R][i]-b[L-1][i]>=2)
            {
                ans=i;
                break;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

总结:
1.学到了在素数筛法中记录合数素因子种类数的方法
2.一开始我也打表看了看,但是没有想到用一个二维数组记录区间内的素因子种类数,所以这一点的思维性还是欠缺的0.0
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值