HDU-Just do it

Just do it

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1228 Accepted Submission(s): 720

Problem Description

There is a nonnegative integer sequence a1…n of length n. HazelFan wants to do a type of transformation called prefix-XOR, which means a1…n changes into b1…n, where bi equals to the XOR value of a1,…,ai. He will repeat it for m times, please tell him the final sequence.

Input

The first line contains a positive integer T(1≤T≤5), denoting the number of test cases.
For each test case:
The first line contains two positive integers n,m(1≤n≤2×105,1≤m≤109).
The second line contains n nonnegative integers a1…n(0≤ai≤230−1).

Output

For each test case:
A single line contains n nonnegative integers, denoting the final sequence.

Sample Input

2
1 1
1
3 3
1 2 3

Sample Output

1
1 3 1

题意:

给出数组a,和整数m,求出数组a按照b[i]=a[1]^a[2]^….^a[i],所有的b[i]更新完之后,b[i]变成新的a[i],重复m次。
解题思路:
做这一题首先需要明确的是,某个数如果异或了偶次,就相当于没有异或,如果异或了奇数次,就相当于只异或了一次(因为异或偶数次,就相互抵消了)
接下来就只需要算每个数 对要求的数的贡献是奇数次还是偶数次就行了,在纸上写一些,找一下规律(拿第一个数的贡献为例,后面的可以类比):
一 a b c d
二 a a^b a^b^c a^b^c^d
三 a a^a^b a^a^a^b^b^c a^a^a^a^b^b^b^c^c^d
通过上面可以看出,a对各项的贡献为:
第一次 1 0 0 0 0
第二次 1 1 1 1 1
第三次 1 2 3 4 5
第四次 1 3 6 10 15
发现,第一个数对后面的数的贡献数是一个杨辉三角,那么就可以推出:a对第x次变换第y项的贡献是C(x+y-2,y-1)次;后面的同样也是杨辉三角(这里不一 一例举),因为是杨辉三角,所以第一个数对第2个数如果是奇数次异或,那么第二个数对第三个数也是奇数次异或,后面的情况同理。c[m][n]为奇数的判断条件为n&m==m(具体为啥,我也不知道…..),这些都明白后,就只剩下写代码了:

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
const int maxn = 2e5 + 10;
using namespace std;

long long  a[maxn];
long long  b[maxn];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(b,0,sizeof(b));
        int n, m;
        scanf("%d %d",&n,&m);
        for(int i = 1; i <= n; i++)
            scanf("%d",&a[i]);
        for(int i = 1; i <= n; i++)
        {
            int x = i + m - 2;
            int y = i - 1;
            if((x & y) == y)
            {
                for(int j = i; j <= n; j++)
                    b[j] ^= a[j - i + 1];
            }
        }
        for(int i = 1; i < n; i++)
            printf("%d ",b[i]);
        printf("%d\n",b[n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值