hdu4902(线段树 修改区间值)这个代码不够简洁

Nice boat

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2520    Accepted Submission(s): 1144


Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

Let us continue our story, z*p(actually you) defeat the 'MengMengDa' party's leader, and the 'MengMengDa' party dissolved. z*p becomes the most famous guy among the princess's knight party. 

One day, the people in the party find that z*p has died. As what he has done in the past, people just say 'Oh, what a nice boat' and don't care about why he died.

Since then, many people died but no one knows why and everyone is fine about that. Meanwhile, the devil sends her knight to challenge you with Algorithm contest.

There is a hard data structure problem in the contest:

There are n numbers a_1,a_2,...,a_n on a line, everytime you can change every number in a segment [l,r] into a number x(type 1), or change every number a_i in a segment [l,r] which is bigger than x to gcd(a_i,x) (type 2).

You should output the final sequence.
 

Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains a integers n.
The next line contains n integers a_1,a_2,...,a_n separated by a single space.
The next line contains an integer Q, denoting the number of the operations.
The next Q line contains 4 integers t,l,r,x. t denotes the operation type.

T<=2,n,Q<=100000
a_i,x >=0
a_i,x is in the range of int32(C++)
 

Output
For each test case, output a line with n integers separated by a single space representing the final sequence.
Please output a single more space after end of the sequence
 

Sample Input
  
  
1 10 16807 282475249 1622650073 984943658 1144108930 470211272 101027544 1457850878 1458777923 2007237709 10 1 3 6 74243042 2 4 8 16531729 1 3 4 1474833169 2 1 8 1131570933 2 7 9 1505795335 2 3 7 101929267 1 4 10 1624379149 2 2 8 2110010672 2 6 7 156091745 1 2 5 937186357
 

Sample Output
  
  
16807 937186357 937186357 937186357 937186357 1 1 1624379149 1624379149 1624379149
 

Author
WJMZBMR
 

Source
 

Recommend
We have carefully selected several similar problems for you:   6253  6252  6251  6250  6249 
#include<iostream>
#include<cstdio>
#include<string>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<list>
#include<set>
#include<iomanip>
#include<cstring>
#include<cctype>
#include<cmath>
#include<cstdlib>
#include<ctime>
#include<cassert>
#include<sstream>
#include<algorithm>
using namespace std;
const int N = 100005;
#define MOD 1000000007
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
typedef long long ll;
#define mid (l+r>>1)
#define lc (d<<1)
#define rc (d<<1|1)

struct Tr
{
    int v,lzx;//lzx为懒标记,v为区间最大值
} tr[N<<2];

struct Q        //记录询问
{
    int t,l,r,x;//操作,左区间,右区间,修改的值
} que[N];

int val[N];//原数列

void Push(int d)//区间最大值
{
    tr[d].v=max(tr[lc].v,tr[rc].v);
}

void build(int d,int l,int r)//建树
{
    if(l==r)
    {
        tr[d].v=val[l];
        tr[d].lzx=-1;
        return;
    }
    tr[d].lzx=-1;
    build(lc,l,mid);
    build(rc,mid+1,r);
    Push(d);
}

void lazy(int d)//懒操作
{
    if(tr[d].lzx!=-1)//如果该区间被修改,则修改左右子区间
    {
        tr[lc].lzx=tr[d].lzx,tr[rc].lzx=tr[d].lzx;
        tr[lc].v=tr[d].lzx,tr[rc].v=tr[d].lzx;
        tr[d].lzx=-1;
    }
}
int gcd(int a,int b)//最大公约数
{
    return a%b==0?b:gcd(b,a%b);
}

void updatex(int d,int l,int r,int L,int R,int x)//操作1,把[L,R]区间的数字都变成x
{
    if(l==L&&r==R)
    {
        tr[d].lzx=x;
        tr[d].v=x;
        return;
    }
    lazy(d);
    if(R<=mid) updatex(lc,l,mid,L,R,x);
    else if(L>mid) updatex(rc,mid+1,r,L,R,x);
    else updatex(lc,l,mid,L,mid,x),updatex(rc,mid+1,r,mid+1,R,x);
    Push(d);
}

void update(int d,int l,int r,int L,int R,int x)//操作2,把[L,R]区间中比x大的数字变成和x的最大公约数
{
    if(l==L&&r==R)
    {
        if(tr[d].v<=x) return;//区间最大值小于x,不做修改
        if(tr[d].lzx!=-1)//懒标记不为-1,对整个区间修改gcd
        {
            tr[d].lzx=gcd(tr[d].lzx,x);
            tr[d].v=tr[d].lzx;
            if(l==r) val[l]=tr[d].lzx;//如果是叶节点,原值上修改
            return;
        }
        if(l==r)//如果是叶节点,原值上修改
        {
            if(val[l]>x) val[l]=gcd(val[l],x);
            return;
        }
        lazy(d);
        update(lc,l,mid,L,mid,x);
        update(rc,mid+1,r,mid+1,R,x);
        Push(d);
        return;
    }
    lazy(d);
    if(R<=mid) update(lc,l,mid,L,R,x);
    else if (L>mid) update(rc,mid+1,r,L,R,x);
    else update(lc,l,mid,L,mid,x),update(rc,mid+1,r,mid+1,R,x);
    Push(d);
}

void out(int d,int l,int r)//输出结果
{
    if(tr[d].lzx!=-1)
    {
        for(int i=l;i<=r;i++)
            printf("%d ",tr[d].lzx);
        return;
    }
    if(l==r)
    {
        printf("%d ",val[l]);
        return;
    }
    lazy(d);
    out(lc,l,mid);
    out(rc,mid+1,r);
}

int main()
{
    int T,n,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&val[i]);
        build(1,1,n);
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
            scanf("%d%d%d%d",&que[i].t,&que[i].l,&que[i].r,&que[i].x);
        for(int i=1;i<=m;i++)
        {
            if(que[i].t==1)
                updatex(1,1,n,que[i].l,que[i].r,que[i].x);
            else
                update(1,1,n,que[i].l,que[i].r,que[i].x);
        }
        out(1,1,n);
        puts("");
    }
    return 0;
}















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值