Determine whether the concatenation of a and b in this order is a square number.



Problem Statement

AtCoDeer the deer has found two positive integers, a and b. Determine whether the concatenation of a and b in this order is a square number.

Constraints

  • 1 a,b 100
  • a and b are integers.

Input

Input is given from Standard Input in the following format:  a b

Output

If the concatenation of a and b in this order is a square number, print Yes; otherwise, print No.


Sample Input :1 21

Sample Output :Yes

import java.util.Scanner;

public class Main {  

public static void main(String[] args){
    int a,b;
    int count=0;
    Scanner scan=new Scanner(System.in);
    a=scan.nextInt();
    b=scan.nextInt();
    do{
     b/=10;
     count++;
    }while(b>0);
    if(Math.sqrt((a*Math.pow(10, count))+b)%1==0){
     System.out.print("Yes");
    }
    else{
     System.out.print("No");
    }  
   } 
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值