You went shopping to buy cakes and donuts with X yen



Problem Statement

You went shopping to buy cakes and donuts with X yen (the currency of Japan).

First, you bought one cake for A yen at a cake shop. Then, you bought as many donuts as possible for B yen each, at a donut shop.

How much do you have left after shopping?

Constraints

  • 1A,B1 000
  • A+BX10 000
  • X, A and B are integers.

Input

Input is given from Standard Input in the following format:

X
A
B

Output

Print the amount you have left after shopping.


Sample Input 1


1234
150
100

Sample Output 1


84

You have 1234150=1084 yen left after buying a cake. With this amount, you can buy 10 donuts, after which you have 84 yen left.

代码:运行环境MyEclipse IDE1.6

import java.util.Scanner;

public class Main {

public static void main(String[] args){
    int X,A,B,m;
    Scanner scan=new Scanner(System.in);
    X=scan.nextInt();
    A=scan.nextInt();
    B=scan.nextInt();
    m=(X-A)%B;
    if(A+B<=X){
     System.out.println(m);
    }
    else{
     System.out.print("input error!");
    }
   }}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值