In how many ways can we select some of these coins so that they are X yen in total?

Problem Statement

You have A 500-yen coins, B 100-yen coins and C 50-yen coins (yen is the currency of Japan). In how many ways can we select some of these coins so that they are X yen in total?

Coins of the same kind cannot be distinguished. Two ways to select coins are distinguished when, for some kind of coin, the numbers of that coin are different.

Constraints

  • 0A,B,C50
  • A+B+C1
  • 50X20 000
  • A, B and C are integers.
  • X is a multiple of 50.

Input

Input is given from Standard Input in the following format:

A
B
C
X

Output

Print the number of ways to select coins.


Sample Input 1


2
2
2
100

Sample Output 1


2

There are two ways to satisfy the condition:

  • Select zero 500-yen coins, one 100-yen coin and zero 50-yen coins.
  • Select zero 500-yen coins, zero 100-yen coins and two 50-yen coins

代码:

import java.util.Scanner;

public class Main {

    public static void main(String[] args){
     int A,B,C,X;
     Scanner scan=new Scanner(System.in);
     //System.out.print("Please input a,b,c,x");
      A=scan.nextInt();
      B=scan.nextInt();
      C=scan.nextInt();
      X=scan.nextInt();
     int count=0;
     for(int i=0;i<=A;i++){
      for(int j=0;j<=B;j++){
       for(int k=0;k<=C;k++){
         int total=(i*500)+(j*100)+(k*50);
           if(total==X){
            count++;
           }
       }       
      }
     }
     System.out.print(count);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值