L1-028. 判断素数
时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越
本题的目标很简单,就是判断一个给定的正整数是否素数。
输入格式:
输入在第一行给出一个正整数N(<=10),随后N行,每行给出一个小于231的需要判断的正整数。
输出格式:
对每个需要判断的正整数,如果它是素数,则在一行中输出“Yes”,否则输出“No”。
输入样例:2
11
111
输出样例:
Yes
No
#include<bits/stdc++.h>
using namespace std;
int f(int x){
int i;
if(x==1)
return 0;
for(i=2;i<=sqrt(x);i++){
if(x%i==0)
return 0;
}
return 1;
}
int main(){
int a,n;
scanf("%d",&n);
while(n--){
scanf("%d",&a);
if(f(a)){
cout<<"Yes"<<endl;
}else{
cout<<"No"<<endl;
}
}
return 0;
}
VC6 通过
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
int main(){
int n,i,j;
int flag=0;
int num;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&num);
flag=0;
if(num==1)
flag=1;
for(j=2;j<=sqrt(num);j++)
{
if(num%j==0)
{
flag=1;
}
}
if(flag==1)
printf("No\n");
else
printf("Yes\n");
}
}