HDU 2018中国大学生程序设计竞赛---网络赛

Find Integer----费马大定理

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 6597    Accepted Submission(s): 1852
Special Judge

 

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

Sample Input

1 2 3

Sample Output

4 5

https://blog.csdn.net/BePosit/article/details/82054583

#include<iostream>
#include<cstdio>
using namespace std;
typedef long long ll;
int main(){
    ll t,n,a,b,c;
    scanf("%lld",&t);
    while(t--){
        scanf("%lld%lld",&n,&a);
        if(n==0||n>2){
            printf("-1 -1\n");
        }else if(n==1){
            b=1;
            c=a+b;
            printf("%lld %lld\n",b,c);
        }else{
            if(a%2==0){
                a/=2;
                b=a*a-1;
                c=a*a+1;
            }else{
                a--;
                a/=2;
                b=2*a*a+2*a;
                c=b+1;
            }
            printf("%lld %lld\n",b,c);
        }
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值