北大暑期训练-------网络流算法

 

目录

 

 

POJ 1273 Drainage Ditches

 

POJ 1273 Drainage Ditches

 

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

USACO 93

这是一个裸的网络流的问题

有n条边,m个点,从源点到汇点,找最大流。

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<string.h> 
using namespace std;
const int maxn=999999999;
int G[300][300];
int Prev[300];//路径上每个节点的前驱节点 
bool visited[300];
int n,m;//m是顶点数目,顶点编号从1开始,1是源点,m是汇点 n是边数 
unsigned Augment()
{
	int v;
	deque<int>q;
	memset(Prev,0,sizeof(Prev));
	memset(visited,0,sizeof(visited));
	Prev[1]=0;
	visited[1]=1;
	q.push_back(1);
	bool bFindPath=false;
//用bfs寻找一条源到汇的可行路径 
	while(!q.empty())
	{
		v=q.front();
		q.pop_front();
		for(int i=1;i<=m;i++)
		{
			if(G[v][i]>0 && !visited[i])
			{//必须是依然有容量的边,才可以走 
				Prev[i]=v;
				visited[i]=1;
				if(i==m)
				{
					bFindPath=true;
					q.clear();
					break;
				}
				else
				{
					q.push_back(i);
				}
			}
		}
	}
	if(!bFindPath)
	   return 0;
	int nMinFlow=maxn;
	v=m;
//寻找源汇路径上容量最小的边,其容量就是此次增加的总流量 
	while(Prev[v])
	{
		nMinFlow=min(nMinFlow,G[Prev[v]][v]);
		v=Prev[v];
	}
	v=m;
//增加反向边,沿此路径增加反向边,同时修改路径上的每一条边的容量 
	while(Prev[v])
	{
		G[Prev[v]][v]-=nMinFlow;
		G[v][Prev[v]]+=nMinFlow;
		v=Prev[v];
	}
	return nMinFlow;
} 
int main()
{
	while(cin>>n>>m)
	{//m是顶点数目,顶点编号从1开始 
	     int s,e,c;
	     memset(G,0,sizeof(G));
	     for(int i=0;i<n;i++)
	     {
	     	cin>>s>>e>>c;
	     	G[s][e]+=c;//两点之间可能有多条边  
		 }
		 unsigned int maxFlow=0;
		 unsigned int ans;
		 while(ans=Augment())
		   maxFlow+=ans;
		cout<<maxFlow<<endl;
	}
	return 0;
}

用Dinic算法的做法

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<queue>
#include<vector>
#include<string.h>
#include<algorithm>
using namespace std;

#define INF 99999999
int G[300][300];
bool visited[300];
int Layer[300];
int n,m;//n是路的条数,m是点的个数(1是源点,m是汇点) 
bool CountLayer()
{
	memset(Layer,0xff,sizeof(Layer));//Layer都初始化为-1 
	deque<int>q;
	Layer[1]=0;
	q.push_back(1);
	while(!q.empty())
	{
		int v=q.front();
		q.pop_front();
		for(int i=1;i<=m;i++)
		{
			if(G[v][i]>0 && Layer[i]==-1)
			{//Layer[i]==-1代表i还没有被访问过 
				Layer[i]=Layer[v]+1;
				if(i==m)//分层能分到汇点,证明是一条由源点流向汇点的一条路径 
				  return true;
				else
				  q.push_back(i);
			}
		}
	}
	return false;
}
int Dinic()
{
	int nMaxFlow=0;
	int i;
	deque<int>q;//DFS用的栈 
	while(CountLayer())
	{
		q.push_back(1);//源点入栈 
		memset(visited,0,sizeof(visited));
		visited[1]=1;
		while(!q.empty())
		{
			int nd=q.back(); 
			if(nd==m)//nd代表汇点
			{
				  int nMinFlow=INF;//在栈里面找流量最小的边 
				  int nMin_vs;//容量最小的边的点 
				  for(i=1;i<q.size();i++)
				  {
				  	 int vs=q[i-1];
				  	 int ve=q[i];
				  	if(G[vs][ve]>0)
				  	{
				  	   	if(nMinFlow>G[vs][ve])
				  	   	{
				  	       nMinFlow=G[vs][ve];
						   nMin_vs=vs;		
					    }
					}
				  }
				  //增广,改图 
				  nMaxFlow+=nMinFlow;
				  for(i=1;i<q.size();i++)
				  {
				  	int vs=q[i-1];
				  	int ve=q[i];
				  	G[vs][ve]-=nMinFlow;//修改边的流量 
				  	G[ve][vs]+=nMinFlow;//增加反向边 
				  }
				  //退栈到nMinFlow成为栈顶,以便继续DFS 
				  while(!q.empty() && q.back()!=nMin_vs)
				  {
				  	visited[q.back()]=0;
				  	q.pop_back();
				  }
			}
			else//nd不是汇点 
			{
				for( i=1;i<=m;i++)
				{
					if(G[nd][i]>0 && Layer[i]==Layer[nd]+1 && visited[i]==0)
					{//只往下一层的没有走过的节点走 
						visited[i]=1;
						q.push_back(i);
						break;
					}
				}
				if(i>m)//找不到下一个点 
				{
					q.pop_back();//回溯 
				}
			}
		}
	}
	return nMaxFlow;
}
int main()
{
   while(cin>>n>>m)
   {
   	   int s,e,c;
   	   memset(G,0,sizeof(G));
   	   for(int i=1;i<=n;i++)
   	   {
    	   cin>>s>>e>>c;
   	       G[s][e]+=c;//俩个点之间可能有多条边  	   	
	   }
   	   cout<<Dinic()<<endl;
   }
return 0;
}

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值